Read the docs

Stored XSS in ApostropheCMS via unescaped widget style attribute

Priority MEDIUM 58CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

ApostropheCMS apostrophe npm package before 4.34.0 is affected. Its wrapper serializer does not HTML-encode a project-defined free-form widget style field, so a quote from an editor can break out of the inline style attribute (CWE-79). A low-privileged editor can store script that runs in the browser of a user who views the rendered published content or an affected draft.

Written with Claude Haiku 5.5 from the sources below · 2026-10-28

Description from the CNA

ApostropheCMS is an open-source Node.js content management system. Prior to 4.34.0, a project-defined free-form widget style field can carry an editor-controlled quote into an inline style attribute because the wrapper serializer does not apply HTML-attribute encoding. The quote can terminate the style attribute and inject executable attributes when published content, or an affected draft viewed by a higher-privileged user, is rendered. This issue is fixed in version 4.34.0.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00304 23rd percentileScored 2026-11-07
Fix Fixed apostrophe (apostrophecms): 4.34.0apostrophe (npm): 4.34.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
apostrophecmsapostrophebefore 4.34.04.34.0Patch availableCNA
—apostrophe (npm)before 4.34.04.34.0Patch availableGHSA-7jg5-frgc-c67w
  • apostrophe Vendorapostrophecms Affected before 4.34.0 Fixed in 4.34.0 Patch available CNA
  • apostrophe (npm) Vendor— Affected before 4.34.0 Fixed in 4.34.0 Patch available GHSA-7jg5-frgc-c67w

CPE names Threatist (inferred) · 1

Inferred from how NVD named this product before; not given by a source.

CPEVersionsRoleVendor
cpe:2.3:a:apostrophecms:apostrophecms:*:*:*:*:*:*:*:*——apostrophecms
  • cpe:2.3:a:apostrophecms:apostrophecms:*:*:*:*:*:*:*:* Versions — — ·apostrophecms

Remediation

Upgrade the npm package apostrophe to version 4.34.0, which fixes this issue. The sources list no fixed version for the apostrophecms vendor entry, but the npm entry for apostrophe lists 4.34.0 as fixed.

Written with Claude Haiku 5.5 from the sources below · 2026-10-28

  • Fix · CNA apostrophe (apostrophecms) Fixed in 4.34.0
  • Fix · GHSA-7jg5-frgc-c67w apostrophe (npm) Fixed in 4.34.0 Advisory →

Timeline

  1. 2026-10-20 Threatist record created from CVE-2026-112958
  2. 2026-10-20 CISA SSVC decision points changed
  3. 2026-10-21 Alias added: GHSA-7jg5-frgc-c67w
  4. 2026-10-21 Fix available: npm/[email protected] · GHSA-7jg5-frgc-c67w
  5. 2026-10-21 CVSS score added · GHSA-7jg5-frgc-c67w
  6. 2026-10-21 Weakness changed · GHSA-7jg5-frgc-c67w
  7. 2026-10-21 6 new references · GHSA-7jg5-frgc-c67w

References

  • TI-2026-25223 ApostropheCMS has Arbitrary File Write (Zip Slip / Path Traversal) in Import-Export Gzip Extraction CVSS 3.1CRITICAL 10.0
  • TI-2026-32848 Apostrophe has default XSS via `xmp` raw-text passthrough in `sanitize-html` CVSS 3.1CRITICAL 9.3
  • TI-2026-38664 @apostrophecms/seo Vulnerable to Stored XSS via Unsanitized Google Analytics / GTM ID Injected into Script Tag CVSS 3.1HIGH 8.7
  • TI-2026-27673 ApostropheCMS: Stored XSS in SEO Fields Leads to Authenticated API Data Exposure in ApostropheCMS CVSS 3.1HIGH 8.7
  • TI-2026-76992 Unauthenticated resource exhaustion via ApostropheCMS import routes CVSS 3.1HIGH 7.5
  • TI-2026-76974 ApostropheCMS leaves rejected CSV uploads in temporary directory CVSS 3.1HIGH 7.5
See all 65 →

Sources