Read the docs

Missing authorization in ApostropheCMS notification endpoints

Priority MEDIUM 51CWE-639Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
High
Impact type
Security bypass
Confidentiality · integrity · availability
None · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-639.

Summary

ApostropheCMS (apostrophe npm package) is affected before 4.33.0. Its notification module exposes PATCH and DELETE REST endpoints that change the MongoDB collection directly without checking authentication or whether the requester owns the notification, a missing authorization flaw (CWE-862). An unauthenticated remote attacker who obtains a valid notification ID can modify or permanently delete another user's notification.

Written with Claude Haiku 5.5 from the sources below · 2026-10-29

Description from the CNA

ApostropheCMS is an open-source Node.js content management system. Prior to 4.33.0, the notification module exposes PATCH and DELETE REST endpoints that perform operations directly on the underlying MongoDB collection without verifying that the requester is authenticated or owns the target notification. As a result, an unauthenticated attacker who obtains a valid notification ID can modify or permanently delete another user's notification. This issue is fixed in version 4.33.0.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00349 28th percentileScored 2026-11-07
Fix Fixed apostrophe (apostrophecms): 4.33.0apostrophe (npm): 4.33.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
apostrophecmsapostrophebefore 4.33.04.33.0Patch availableCNA
—apostrophe (npm)before 4.33.04.33.0Patch availableGHSA-vwwx-px9w-crrc
  • apostrophe Vendorapostrophecms Affected before 4.33.0 Fixed in 4.33.0 Patch available CNA
  • apostrophe (npm) Vendor— Affected before 4.33.0 Fixed in 4.33.0 Patch available GHSA-vwwx-px9w-crrc

CPE names Threatist (inferred) · 1

Inferred from how NVD named this product before; not given by a source.

CPEVersionsRoleVendor
cpe:2.3:a:apostrophecms:apostrophecms:*:*:*:*:*:*:*:*——apostrophecms
  • cpe:2.3:a:apostrophecms:apostrophecms:*:*:*:*:*:*:*:* Versions — — ·apostrophecms

Remediation

Upgrade the apostrophe npm package to version 4.33.0 or later.

Written with Claude Haiku 5.5 from the sources below · 2026-10-29

  • Fix · CNA apostrophe (apostrophecms) Fixed in 4.33.0
  • Fix · GHSA-vwwx-px9w-crrc apostrophe (npm) Fixed in 4.33.0 Advisory →

Timeline

  1. 2026-10-20 Threatist record created from CVE-2026-113665
  2. 2026-10-21 Alias added: GHSA-vwwx-px9w-crrc
  3. 2026-10-21 Fix available: npm/[email protected] · GHSA-vwwx-px9w-crrc
  4. 2026-10-21 CVSS score added · GHSA-vwwx-px9w-crrc
  5. 2026-10-21 Weakness changed · GHSA-vwwx-px9w-crrc
  6. 2026-10-21 5 new references · GHSA-vwwx-px9w-crrc
  7. 2026-10-28 CISA SSVC decision points changed
  8. 2026-10-28 Priority changed: LOW → MEDIUM

References

  • TI-2026-25223 ApostropheCMS has Arbitrary File Write (Zip Slip / Path Traversal) in Import-Export Gzip Extraction CVSS 3.1CRITICAL 10.0
  • TI-2026-32848 Apostrophe has default XSS via `xmp` raw-text passthrough in `sanitize-html` CVSS 3.1CRITICAL 9.3
  • TI-2026-38664 @apostrophecms/seo Vulnerable to Stored XSS via Unsanitized Google Analytics / GTM ID Injected into Script Tag CVSS 3.1HIGH 8.7
  • TI-2026-27673 ApostropheCMS: Stored XSS in SEO Fields Leads to Authenticated API Data Exposure in ApostropheCMS CVSS 3.1HIGH 8.7
  • TI-2026-76992 Unauthenticated resource exhaustion via ApostropheCMS import routes CVSS 3.1HIGH 7.5
  • TI-2026-76974 ApostropheCMS leaves rejected CSV uploads in temporary directory CVSS 3.1HIGH 7.5
See all 65 →

Sources