ApostropheCMS page REST API exposes private page content
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-863.
Summary
The apostrophe npm package, the ApostropheCMS content management system, is affected before 4.33.0. Incorrect authorization (CWE-863) in the page REST API returns full page documents without permission checks, bypassing viewRole, private and loginRequired page settings. An unauthenticated visitor or a low-privilege contributor can read admin-only and non-public page content by _id or slug.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
ApostropheCMS is an open-source Node.js content management system. Prior to 4.33.0, the core page REST API reads full page documents with .permission(false) in getOne and in the all=1 tree dump, bypassing page-type viewRole, visibility: private, and visibility: loginRequired checks. Unauthenticated visitors and low-privilege contributors can read admin-only and non-public page content by _id/slug. This issue is fixed in version 4.33.0.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| apostrophecms | apostrophe | before 4.33.0 | 4.33.0 | Patch available | CNA |
| — | apostrophe (npm) | before 4.33.0 | 4.33.0 | Patch available | GHSA-2j32-q6rx-h844 |
- apostrophe Vendorapostrophecms Affected before 4.33.0 Fixed in 4.33.0 Patch available CNA
- apostrophe (npm) Vendor— Affected before 4.33.0 Fixed in 4.33.0 Patch available GHSA-2j32-q6rx-h844
CPE names Threatist (inferred) · 1
Inferred from how NVD named this product before; not given by a source.
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apostrophecms:apostrophecms:*:*:*:*:*:*:*:* | — | — | apostrophecms |
- cpe:2.3:a:apostrophecms:apostrophecms:*:*:*:*:*:*:*:* Versions — — ·apostrophecms
Remediation
Update the apostrophe npm package to version 4.33.0, which fixes this issue. The sources list no fixed version for ApostropheCMS.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
- Fix · CNA apostrophe (apostrophecms) Fixed in 4.33.0
- Fix · GHSA-2j32-q6rx-h844 apostrophe (npm) Fixed in 4.33.0 Advisory →
Timeline
- 2026-10-20 Threatist record created from CVE-2026-113670
- 2026-10-21 Alias added: GHSA-2j32-q6rx-h844
- 2026-10-21 Fix available: npm/[email protected] · GHSA-2j32-q6rx-h844
- 2026-10-21 CVSS score added · GHSA-2j32-q6rx-h844
- 2026-10-21 Weakness changed · GHSA-2j32-q6rx-h844
- 2026-10-21 5 new references · GHSA-2j32-q6rx-h844
References
Other 5
- https://github.com/apostrophecms/apostrophe/security/advisories/GHSA-2j32-q6rx-h844
- https://github.com/apostrophecms/apostrophe/commit/9500b8b0e1d630d5e07fbb5fd2c25ed0943845ce
- https://github.com/apostrophecms/apostrophe/commit/f84fd41cbf6c22eb8d0008fc9c25df1f7130b350
- https://github.com/apostrophecms/apostrophe/releases/tag/[email protected]
- https://github.com/apostrophecms/apostrophe
More apostrophecms vulnerabilities
- TI-2026-25223 ApostropheCMS has Arbitrary File Write (Zip Slip / Path Traversal) in Import-Export Gzip Extraction CVSS 3.1CRITICAL 10.0
- TI-2026-32848 Apostrophe has default XSS via `xmp` raw-text passthrough in `sanitize-html` CVSS 3.1CRITICAL 9.3
- TI-2026-38664 @apostrophecms/seo Vulnerable to Stored XSS via Unsanitized Google Analytics / GTM ID Injected into Script Tag CVSS 3.1HIGH 8.7
- TI-2026-27673 ApostropheCMS: Stored XSS in SEO Fields Leads to Authenticated API Data Exposure in ApostropheCMS CVSS 3.1HIGH 8.7
- TI-2026-76992 Unauthenticated resource exhaustion via ApostropheCMS import routes CVSS 3.1HIGH 7.5
- TI-2026-76974 ApostropheCMS leaves rejected CSV uploads in temporary directory CVSS 3.1HIGH 7.5
Sources
- CVE-2026-113670 · CVE Program
- CVE-2026-113670 · NVD
- FIRST EPSS
- GHSA-2j32-q6rx-h844 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences