Stored cross-site scripting in Waitlist Woocommerce WordPress plugin
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The xootix Waitlist Woocommerce (Back in stock notifier) WordPress plugin through 2.9.1 has improper neutralization of input during web page generation (CWE-79), which allows stored cross-site scripting. A remote attacker with low privileges needs a user to interact with the affected page, and the impact can extend beyond the plugin's own security scope.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in xootix Waitlist Woocommerce ( Back in stock notifier ) waitlist-woocommerce allows Stored XSS.This issue affects Waitlist Woocommerce ( Back in stock notifier ): from n/a through 2.9.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
The sources list no fixed version for Waitlist Woocommerce ( Back in stock notifier ).
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Timeline
- 2026-10-22 Threatist record created from CVE-2026-114701
- 2026-10-22 Alias added: GHSA-vjmh-mp76-qfx6
- 2026-10-22 CISA SSVC decision points changed
- 2026-10-22 Priority changed: MEDIUM → LOW
More xootix vulnerabilities
- TI-2024-04943 XootiX Framework <= Various Plugin Versions - Missing Authorization to Arbitrary Options Update CVSS 3.1HIGH 8.8
- TI-2022-00152 XootiX Plugins <= Various Versions Cross-Site Request Forgery to Arbitrary Options Update CVSS 3.1HIGH 8.8
- TI-2023-02534 OTP Login Woocommerce & Gravity Forms <= 2.2 - Authentication Bypass to Privilege Escalation CVSS 3.1HIGH 8.1
- TI-2022-22342 WordPress Side Cart Woocommerce (Ajax) Plugin < 2.1 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2020-18886 Login/Signup Popup < 1.5 - Missing Authorization CVSS 3.1HIGH 7.4
- TI-2026-10507 OTP Login & Register Woocommerce <= 2.7.2 - Unauthenticated Authentication Bypass via Brute Force CVSS 3.1MEDIUM 5.3
Sources
- CVE-2026-114701 · CVE Program
- CVE-2026-114701 · NVD
- FIRST EPSS
- GHSA-vjmh-mp76-qfx6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences