Unlimited buffered header sets in lsquic HTTP/3 exhaust memory
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-770.
Summary
In lsquic before 4.9.0, the HTTP/3 implementation does not limit the number of buffered header sets. A remote attacker can use a QPACK amplification attack to make the server consume an excessive amount of memory, as CWE-770 describes.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
In lsquic before 4.9.0, the HTTP/3 implementation can use an excessive amount of memory because the number of buffered header sets is not limited, as demonstrated by a QPACK amplification attack. This is related to header_out_dynamic_entry and es_max_header_list_size.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| litespeedtech | lsquic | before 4.9.0 | 4.9.0 | Patch available | CNA |
- lsquic Vendorlitespeedtech Affected before 4.9.0 Fixed in 4.9.0 Patch available CNA
Remediation
Upgrade lsquic to version 4.9.0.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
- Fix · CNA lsquic (litespeedtech) Fixed in 4.9.0
Timeline
- 2026-10-22 Threatist record created from CVE-2026-115482
- 2026-10-22 CISA SSVC decision points changed
- 2026-10-22 Priority changed: MEDIUM → LOW
- 2026-10-22 Alias added: GHSA-mhr4-9xv4-xpwf
References
More litespeedtech vulnerabilities
- TI-2026-35606 LiteSpeed User-End cPanel Plugin before 2.4.5 allows privilege escalation (possibly to… KEVCVSS 4.0CRITICAL 10.0
- TI-2026-39296 LiteSpeed cPanel plugin before 2.4.8 (as distributed in LiteSpeed WHM PlugIn before… KEVCVSS 3.1HIGH 8.5
- TI-2024-29589 WordPress LiteSpeed Cache plugin < 6.5.0.1 - Unauthenticated Account Takeover via Cookie Leak vulnerability CVSS 3.1CRITICAL 9.8
- TI-2024-18601 WordPress LiteSpeed Cache plugin <= 6.3.0.1 - Unauthenticated Privilege Escalation vulnerability CVSS 3.1CRITICAL 9.8
- TI-2022-00030 Authenticated Remote Code Execution in OpenLiteSpeed Web Server CVSS 3.1HIGH 8.8
- TI-2026-83023 Client certificate bypass over HTTP/3 in OpenLiteSpeed CVSS 4.0HIGH 8.2
Sources
- CVE-2026-115482 · CVE Program
- CVE-2026-115482 · NVD
- FIRST EPSS
- GHSA-mhr4-9xv4-xpwf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences