A2A Server in Strands Agents SDK exposes other tenants' data
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub.
Summary
Amazon Strands Agents SDK for Python before 1.43.0 and Amazon Strands Agents SDK for TypeScript before 1.5.0 do not properly isolate conversation state between callers. An authenticated remote user can read other tenants' conversation history and add persistent instructions that alter model behavior for later callers by sending HTTP requests to the A2A endpoint with a different context_id. The flaw is classified as CWE-488, exposure of a data element to the wrong session.
Written with Claude Haiku 5.5 from the sources below · 2026-10-30
Description from the CNA
The A2A server component in Amazon Strands Agents SDK for Python before 1.43.0 and Amazon Strands Agents SDK for TypeScript before 1.5.0 does not properly isolate conversation state between callers. An authenticated remote user could read other tenants' conversation history and add persistent instructions that alter model behavior for subsequent callers via HTTP requests to the A2A endpoint using a different context_id. To mitigate this issue, users should upgrade to strands-agents 1.43.0 (Python) or @strands-agents/sdk 1.5.0 (TypeScript).
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| AWS | strands-agents | before 1.43.0 | 1.43.0 | Patch available | CNA |
| AWS | strands-agents/sdk | before 1.5.0 | 1.5.0 | Patch available | CNA |
| — | strands-agents (PyPI) | before 1.43.0 | 1.43.0 | Patch available | GHSA-4v6f-7vjh-6x4m |
| — | @strands-agents/sdk (npm) | before 1.5.0 | 1.5.0 | Patch available | GHSA-4v6f-7vjh-6x4m |
- strands-agents VendorAWS Affected before 1.43.0 Fixed in 1.43.0 Patch available CNA
- strands-agents/sdk VendorAWS Affected before 1.5.0 Fixed in 1.5.0 Patch available CNA
- strands-agents (PyPI) Vendor— Affected before 1.43.0 Fixed in 1.43.0 Patch available GHSA-4v6f-7vjh-6x4m
- @strands-agents/sdk (npm) Vendor— Affected before 1.5.0 Fixed in 1.5.0 Patch available GHSA-4v6f-7vjh-6x4m
Remediation
Upgrade strands-agents to 1.43.0 for Python and @strands-agents/sdk to 1.5.0 for TypeScript, which are the fixed versions listed for both packages.
Written with Claude Haiku 5.5 from the sources below · 2026-10-30
- Fix · CNA strands-agents (AWS) Fixed in 1.43.0
- Fix · CNA strands-agents/sdk (AWS) Fixed in 1.5.0
- Fix · GHSA-4v6f-7vjh-6x4m strands-agents (PyPI) Fixed in 1.43.0 Advisory →
- Fix · GHSA-4v6f-7vjh-6x4m @strands-agents/sdk (npm) Fixed in 1.5.0 Advisory →
Timeline
- 2026-10-23 Threatist record created from CVE-2026-115419
- 2026-10-23 Priority changed: MEDIUM → LOW
- 2026-10-23 Alias added: GHSA-4v6f-7vjh-6x4m
- 2026-10-23 Fix available: PyPI/[email protected], npm/@strands-agents/[email protected] · GHSA-4v6f-7vjh-6x4m
- 2026-10-23 CVSS score added · GHSA-4v6f-7vjh-6x4m
- 2026-10-23 Weakness changed · GHSA-4v6f-7vjh-6x4m
- 2026-10-23 13 new references · GHSA-4v6f-7vjh-6x4m
- 2026-10-30 CISA SSVC decision points changed
- 2026-10-30 Priority changed: LOW → MEDIUM
References
Patch 2
Advisory 3
Other 10
- https://github.com/strands-agents/harness-sdk/pull/2628
- https://github.com/strands-agents/harness-sdk/pull/2696
- https://github.com/strands-agents/harness-sdk/commit/398343faad0e485f2e441dab70355c9a52382537
- https://github.com/strands-agents/harness-sdk/commit/403d87847e738e1c73909858d989cedcb67f0afa
- https://github.com/strands-agents/harness-sdk/commit/f8ba9376fe4b8330d526b6480b47c4440150e0cd
- https://aws.amazon.com/security/security-bulletins/2026-146-aws
- https://github.com/strands-agents/harness-sdk
- https://github.com/strands-agents/harness-sdk/releases/tag/python/v1.43.0
- https://github.com/strands-agents/harness-sdk/releases/tag/typescript/v1.5.0
- https://pypi.org/project/strands-agents/1.43.0
More AWS vulnerabilities
- TI-2026-23989 crypto: algif_aead - Revert to operating out-of-place KEVCVSS 3.1HIGH 7.8
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2024-18648 Amazon AWS Amplify CLI before 12.10.1 incorrectly configures the role trust policy of IAM… CVSS 3.1CRITICAL 9.8
- TI-2024-05929 Openssh: regresshion - race condition in ssh allows rce/dos CVSS 3.1HIGH 8.1
- TI-2025-03847 Input validation issue in AWS Amplify Studio UI component properties CVSS 4.0CRITICAL 9.0
- TI-2026-11603 HTTP/2 Stream Parser Confusion Body-Inspection Bypass in Amazon CloudFront with AWS WAF CVSS 4.0HIGH 7.9
Sources
- CVE-2026-115419 · CVE Program
- CVE-2026-115419 · NVD
- FIRST EPSS
- GHSA-4v6f-7vjh-6x4m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences