Read the docs

Denial of service in vLLM via inconsistent multimodal inputs

Priority LOW 36CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
High
Attack requirements
Present
Impact type
—
Confidentiality · integrity · availability
None · None · High
Fix status
Partial Red Hat: 3 without a fix

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and Red Hat.

Summary

vLLM from 0.20.0 before 0.30.0 contains a denial of service vulnerability caused by improper input validation (CWE-20). A remote attacker without privileges or user interaction can crash the engine by sending inconsistent multimodal metadata to the disaggregated /inference/v1/generate endpoint. The inconsistent metadata produces a negative text span during Qwen2.5-VL position construction.

Written with Claude Haiku 5.5 from the sources below · 2026-10-28

Description from the CNA

vLLM from 0.20.0 before 0.30.0 contains a denial of service vulnerability that allows remote attackers to crash the engine by sending inconsistent multimodal metadata to the disaggregated /inference/v1/generate endpoint. Attackers can replay a valid multimodal item with repeated or overlapping mm_placeholders ranges or mismatched kwargs_data and mm_hashes lists, producing a negative text span in Qwen2.5-VL position construction that terminates the engine.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00331 26th percentileScored 2026-11-07
Fix Partial vllm (vllm-project): 0.30.0Red Hat: 3 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
vllm-projectvllm0.20.0 to before 0.30.00.30.0Patch availableCNA
  • vllm Vendorvllm-project Affected 0.20.0 to before 0.30.0 Fixed in 0.30.0 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:vllm:vllm:*:*:*:*:*:*:*:*0.20.0 to before 0.30.0VulnerablevLLM
  • cpe:2.3:a:vllm:vllm:*:*:*:*:*:*:*:* Versions 0.20.0 to before 0.30.0 Vulnerable ·vLLM

Remediation

Upgrade vLLM to version 0.30.0. Red Hat lists Red Hat AI Inference Server, Red Hat Enterprise Linux AI (RHEL AI) 3 and Red Hat OpenShift AI (RHOAI) as affected, with no fix plan available.

Written with Claude Haiku 5.5 from the sources below · 2026-10-28

  • Fix · CNA vllm (vllm-project) Fixed in 0.30.0

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat AI Inference ServerAffectedNo fix yet: Fix deferred
Red Hat Enterprise Linux AI (RHEL AI) 3AffectedNo fix yet: Fix deferred
Red Hat OpenShift AI (RHOAI)AffectedNo fix yet: Fix deferred

Timeline

  1. 2026-10-25 Threatist record created from CVE-2026-116178
  2. 2026-10-25 Affected versions changed · Red Hat
  3. 2026-10-25 CVSS score added · Red Hat
  4. 2026-10-26 CISA SSVC decision points changed
  5. 2026-10-26 Priority changed: MEDIUM → LOW
  6. 2026-10-27 Alias added: GHSA-w9hx-wr9v-56wv
  7. 2026-10-28 CVSS score added · NVD

References

  • TI-2024-10229 Remote Code Execution in vllm-project/vllm CVSS 3.0CRITICAL 9.8
  • TI-2024-08404 Remote Code Execution in vllm-project/vllm CVSS 3.1CRITICAL 9.8
  • TI-2026-36017 vLLM: OpenAI auth bypass CVSS 3.1CRITICAL 9.1
  • TI-2026-63056 vLLM before 0.28.0 Denial of Service via negative token ID CVSS 4.0HIGH 8.7
  • TI-2026-04308 Hardcoded trust_remote_code=True in vllm-project/vllm Bypasses User Security Control CVSS 3.0HIGH 8.8
  • TI-2026-39137 vLLM: Remote DoS in vLLM via Invalid Recovered Token Reinjection CVSS 3.1HIGH 7.5
See all 124 →

Sources