Read the docs

Denial of service and out-of-bounds write in vLLM via stop_token_ids

Priority LOW 31CWE-129Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Partial Red Hat: 3 without a fix

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and Red Hat. Impact type from CWE-129 and the CVSS impact.

Summary

vLLM from 0.20.1 before 0.29.0 fails to validate stop_token_ids, so out-of-vocabulary IDs are accepted (CWE-129). A remote attacker with low privileges can send chat, completion, generate, or batch requests with invalid IDs to crash the engine or write outside the V2 runner's logits buffer.

Written with Claude Haiku 5.5 from the sources below · 2026-10-29

Description from the CNA

vLLM from 0.20.1 before 0.29.0 contains an improper input validation vulnerability that allows remote attackers to crash the engine by supplying out-of-vocabulary stop_token_ids. Attackers can send OpenAI chat, completion, generate, or batch requests with invalid IDs to terminate the engine or write outside the V2 runner's logits buffer.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00374 31st percentileScored 2026-11-07
Fix Partial vllm (vllm-project): 0.29.0Red Hat: 3 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
vllm-projectvllm0.20.1 to before 0.29.00.29.0Patch availableCNA
  • vllm Vendorvllm-project Affected 0.20.1 to before 0.29.0 Fixed in 0.29.0 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:vllm:vllm:*:*:*:*:*:*:*:*0.20.1 to before 0.29.0VulnerablevLLM
  • cpe:2.3:a:vllm:vllm:*:*:*:*:*:*:*:* Versions 0.20.1 to before 0.29.0 Vulnerable ·vLLM

Remediation

Upgrade vllm to version 0.29.0, which fixes the flaw. Red Hat lists no available plan for Red Hat AI Inference Server, Red Hat Enterprise Linux AI (RHEL AI) 3, and Red Hat OpenShift AI (RHOAI).

Written with Claude Haiku 5.5 from the sources below · 2026-10-29

  • Fix · CNA vllm (vllm-project) Fixed in 0.29.0

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat AI Inference ServerAffectedNo fix yet: Fix deferred
Red Hat Enterprise Linux AI (RHEL AI) 3AffectedNo fix yet: Fix deferred
Red Hat OpenShift AI (RHOAI)AffectedNo fix yet: Fix deferred

Timeline

  1. 2026-10-25 Threatist record created from CVE-2026-116181
  2. 2026-10-25 Affected versions changed · Red Hat
  3. 2026-10-25 CVSS score added · Red Hat
  4. 2026-10-26 Priority changed: MEDIUM → LOW
  5. 2026-10-27 Alias added: GHSA-f2x4-7hx3-gxfp
  6. 2026-10-29 CISA SSVC decision points changed

References

  • TI-2024-10229 Remote Code Execution in vllm-project/vllm CVSS 3.0CRITICAL 9.8
  • TI-2024-08404 Remote Code Execution in vllm-project/vllm CVSS 3.1CRITICAL 9.8
  • TI-2026-36017 vLLM: OpenAI auth bypass CVSS 3.1CRITICAL 9.1
  • TI-2026-63056 vLLM before 0.28.0 Denial of Service via negative token ID CVSS 4.0HIGH 8.7
  • TI-2026-04308 Hardcoded trust_remote_code=True in vllm-project/vllm Bypasses User Security Control CVSS 3.0HIGH 8.8
  • TI-2026-39137 vLLM: Remote DoS in vLLM via Invalid Recovered Token Reinjection CVSS 3.1HIGH 7.5
See all 124 →

Sources