Denial of service in vLLM DeepSeek-OCR image processing
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 3 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-617.
Summary
vLLM from 0.11.1 before 0.32.0 is affected. The DeepSeek-OCR, DeepSeek-OCR-2 and Unlimited-OCR image path hits a reachable assertion (CWE-617) when a legal image whose normalized pixels sum to zero is alone in its encoder batch. A remote client that can reach the OpenAI-compatible API can submit such an image and shut down the engine for all users.
Written with Claude Haiku 5.5 from the sources below · 2026-10-30
Description from the CNA
vLLM is an inference and serving engine for large language models. From 0.11.1 until 0.32.0, the DeepSeek-OCR, DeepSeek-OCR-2, and Unlimited-OCR image path allows a remote client that can reach the OpenAI-compatible API to submit a legal image whose normalized pixels sum to zero when that image is alone in its per-step encoder batch. _parse_and_validate_image_input returns no embedding, embed_multimodal propagates that value, and sanity_check_mm_encoder_outputs triggers a fatal assertion that shuts down the engine for all users. This issue is fixed in version 0.32.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| vllm-project | vllm | 0.11.1 to before 0.32.0 | 0.32.0 | Patch available | CNA |
| — | vllm (PyPI) | 0.11.1 to before 0.32.0 | 0.32.0 | Patch available | GHSA-gq5q-89c7-vhvx |
- vllm Vendorvllm-project Affected 0.11.1 to before 0.32.0 Fixed in 0.32.0 Patch available CNA
- vllm (PyPI) Vendor— Affected 0.11.1 to before 0.32.0 Fixed in 0.32.0 Patch available GHSA-gq5q-89c7-vhvx
Remediation
Upgrade vLLM to version 0.32.0, the fixed version listed for PyPI. Red Hat has no fix plan available for Red Hat AI Inference Server, Red Hat Enterprise Linux AI (RHEL AI) 3 and Red Hat OpenShift AI (RHOAI).
Written with Claude Haiku 5.5 from the sources below · 2026-10-30
- Fix · CNA vllm (vllm-project) Fixed in 0.32.0
- Fix · GHSA-gq5q-89c7-vhvx vllm (PyPI) Fixed in 0.32.0 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat AI Inference Server | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux AI (RHEL AI) 3 | Affected | No fix yet: Fix deferred |
| Red Hat OpenShift AI (RHOAI) | Affected | No fix yet: Fix deferred |
Timeline
- 2026-10-26 Threatist record created from CVE-2026-115914
- 2026-10-27 Affected versions changed · Red Hat
- 2026-10-27 CVSS score added · Red Hat
- 2026-10-27 Priority changed: MEDIUM → LOW
- 2026-10-28 Alias added: GHSA-gq5q-89c7-vhvx
- 2026-10-28 Fix available: PyPI/[email protected] · GHSA-gq5q-89c7-vhvx
- 2026-10-28 CVSS score added · GHSA-gq5q-89c7-vhvx
- 2026-10-28 Weakness changed · GHSA-gq5q-89c7-vhvx
- 2026-10-28 6 new references · GHSA-gq5q-89c7-vhvx
- 2026-10-30 CISA SSVC decision points changed
References
Patch 3
More vllm-project vulnerabilities
- TI-2024-10229 Remote Code Execution in vllm-project/vllm CVSS 3.0CRITICAL 9.8
- TI-2024-08404 Remote Code Execution in vllm-project/vllm CVSS 3.1CRITICAL 9.8
- TI-2026-36017 vLLM: OpenAI auth bypass CVSS 3.1CRITICAL 9.1
- TI-2026-63056 vLLM before 0.28.0 Denial of Service via negative token ID CVSS 4.0HIGH 8.7
- TI-2026-04308 Hardcoded trust_remote_code=True in vllm-project/vllm Bypasses User Security Control CVSS 3.0HIGH 8.8
- TI-2026-39137 vLLM: Remote DoS in vLLM via Invalid Recovered Token Reinjection CVSS 3.1HIGH 7.5
Sources
- CVE-2026-115914 · CVE Program
- CVE-2026-115914 · NVD
- FIRST EPSS
- GHSA-gq5q-89c7-vhvx · GitHub Advisory Database · CC BY 4.0
- CVE-2026-115914 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences