Untrusted image decoding in vLLM enables denial of service
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 1 fixed, 3 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat.
Summary
vLLM before 0.32.0 passes attacker-controlled image bytes to Pillow without restricting the decoder, so the MIME label does not limit the parsed format (CWE-20). An unauthenticated remote attacker can send an EPS payload through image request paths such as parse_image() that reach host components. A host with a vulnerable Ghostscript lets the payload run commands with vLLM's privileges, and Pillow 12.0.0 through 12.2.0 lets it exhaust media-loading workers.
Written with Claude Haiku 5.5 from the sources below · 2026-11-04
Description from the CNA
vLLM is an inference and serving engine for large language models. Prior to 0.32.0, ImageMediaIO passes attacker-controlled image bytes to Pillow through Image.open(BytesIO(data)) without restricting decoder selection, and the MIME label does not constrain the selected format. Image-capable request paths through parse_image() and fetch_image() can therefore dispatch an EPS payload to host components. A host with Ghostscript affected by CVE-2024-29510 can execute commands with the vLLM process's privileges, while environments using Pillow 12.0.0 through 12.2.0 can trigger CVE-2026-59203 and exhaust media-loading workers. Deployments without the applicable vulnerable dependency are not affected by that corresponding impact. This issue is fixed in version 0.32.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| vllm-project | vllm | before 0.32.0 | 0.32.0 | Patch available | CNA |
| — | vllm (PyPI) | before 0.32.0 | 0.32.0 | Patch available | GHSA-h3rc-j82p-2c3h |
- vllm Vendorvllm-project Affected before 0.32.0 Fixed in 0.32.0 Patch available CNA
- vllm (PyPI) Vendor— Affected before 0.32.0 Fixed in 0.32.0 Patch available GHSA-h3rc-j82p-2c3h
Remediation
Upgrade vllm to 0.32.0, which fixes all earlier versions. Red Hat AI Inference Server 3.5 is fixed by RHSA-2026:94702 (CPU), RHSA-2026:94709 (ROCm), RHSA-2026:94717 (Spyre), RHSA-2026:94721 (Gaudi Tech Preview) and RHSA-2026:94738 (CUDA). Red Hat has no fix plan for Red Hat Enterprise Linux AI (RHEL AI) 3, Red Hat OpenShift AI (RHOAI) or other Red Hat AI Inference Server versions.
Written with Claude Haiku 5.5 from the sources below · 2026-11-04
- Fix · CNA vllm (vllm-project) Fixed in 0.32.0
- Fix · GHSA-h3rc-j82p-2c3h vllm (PyPI) Fixed in 0.32.0 Advisory →
Red Hat 5 advisories
- RHSA-2026:94738 Released 2026-11-03 · Red Hat rating CriticalRed Hat AI Inference 3.5.3 (CUDA)
- Red Hat AI Inference Server 3.5 registry.redhat.io/rhaii/vllm-cuda-rhel9
- RHSA-2026:94721 Released 2026-11-03 · Red Hat rating CriticalRed Hat AI Inference Tech Preview 3.5.3 (Gaudi)
- Red Hat AI Inference Server 3.5 registry.redhat.io/rhaii/vllm-gaudi-rhel9
- RHSA-2026:94717 Released 2026-11-03 · Red Hat rating CriticalRed Hat AI Inference 3.5.3 (Spyre)
- Red Hat AI Inference Server 3.5 registry.redhat.io/rhaii/vllm-spyre-rhel9
Show 2 more Red Hat advisories
- RHSA-2026:94709 Released 2026-11-03 · Red Hat rating CriticalRed Hat AI Inference 3.5.3 (ROCm)
- Red Hat AI Inference Server 3.5 registry.redhat.io/rhaii/vllm-rocm-rhel9
- RHSA-2026:94702 Released 2026-11-03 · Red Hat rating CriticalRed Hat AI Inference 3.5.3 (CPU)
- Red Hat AI Inference Server 3.5 registry.redhat.io/rhaii/vllm-cpu-rhel9
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat AI Inference Server | Affected | No fix yet |
| Red Hat Enterprise Linux AI (RHEL AI) 3 | Affected | No fix yet |
| Red Hat OpenShift AI (RHOAI) | Affected | No fix yet |
| Red Hat AI Inference Server 3.5 | Fixed | RHSA-2026:94702, RHSA-2026:94709, RHSA-2026:94717, RHSA-2026:94721, RHSA-2026:94738 |
Not affected: 1 product
- Red Hat OpenShift AI (RHOAI)
Timeline
- 2026-10-26 Threatist record created from CVE-2026-115915
- 2026-10-26 CISA SSVC decision points changed
- 2026-10-26 Priority changed: MEDIUM → LOW
- 2026-10-27 Affected versions changed · Red Hat
- 2026-10-27 CVSS score added · Red Hat
- 2026-10-28 CVSS score added · NVD
- 2026-10-28 Priority changed: LOW → MEDIUM
- 2026-10-28 Alias added: GHSA-h3rc-j82p-2c3h
- 2026-10-28 Fix available: PyPI/[email protected] · GHSA-h3rc-j82p-2c3h
- 2026-10-28 CVSS score added · GHSA-h3rc-j82p-2c3h
- 2026-10-28 Weakness changed · GHSA-h3rc-j82p-2c3h
- 2026-10-28 6 new references · GHSA-h3rc-j82p-2c3h
- 2026-10-30 Affected versions changed · Red Hat
- 2026-11-04 Fix available: RHSA-2026:94717 · Red Hat
- 2026-11-04 Fix available: RHSA-2026:94709 · Red Hat
- 2026-11-04 Fix available: RHSA-2026:94738 · Red Hat
- 2026-11-04 Fix available: RHSA-2026:94702 · Red Hat
- 2026-11-04 Fix available: RHSA-2026:94721 · Red Hat
- 2026-11-04 Fix available: Red Hat AI Inference Server 3.5 · Red Hat
References
Patch 3
More vllm-project vulnerabilities
- TI-2024-10229 Remote Code Execution in vllm-project/vllm CVSS 3.0CRITICAL 9.8
- TI-2024-08404 Remote Code Execution in vllm-project/vllm CVSS 3.1CRITICAL 9.8
- TI-2026-36017 vLLM: OpenAI auth bypass CVSS 3.1CRITICAL 9.1
- TI-2026-63056 vLLM before 0.28.0 Denial of Service via negative token ID CVSS 4.0HIGH 8.7
- TI-2026-04308 Hardcoded trust_remote_code=True in vllm-project/vllm Bypasses User Security Control CVSS 3.0HIGH 8.8
- TI-2026-39137 vLLM: Remote DoS in vLLM via Invalid Recovered Token Reinjection CVSS 3.1HIGH 7.5
Sources
- CVE-2026-115915 · CVE Program
- CVE-2026-115915 · NVD
- FIRST EPSS
- GHSA-h3rc-j82p-2c3h · GitHub Advisory Database · CC BY 4.0
- CVE-2026-115915 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences