Out-of-vocabulary prompt token IDs crash vLLM engine
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 3 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-129 and the CVSS impact.
Summary
vLLM versions before 0.32.0 are affected. An off-by-one error in the maximum token ID check (CWE-193) lets a prompt token ID equal to the vocabulary size pass validation. With tensor-parallel size one and a vocabulary size that is an exact multiple of 64, the embedding layer does not mask that value, which triggers a CUDA device-side assertion and terminates the engine. A remote user with low privileges can crash the inference engine.
Written with Claude Haiku 5.5 from the sources below · 2026-11-02
Description from the CNA
vLLM is an inference and serving engine for large language models. Prior to 0.32.0, vllm/tokenizers/hf.py computes max_token_id with an off-by-one upper bound, allowing a pre-tokenized prompt ID equal to the vocabulary size to pass validation. For a tensor-parallel size of one and an exact multiple-of-64 vocabulary, VocabParallelEmbedding.forward does not mask that value before F.embedding uses it, causing a CUDA device-side assertion and terminating the engine. This issue is fixed in version 0.32.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| vllm-project | vllm | before 0.32.0 | 0.32.0 | Patch available | CNA |
| — | vllm (PyPI) | before 0.32.0 | 0.32.0 | Patch available | GHSA-q97c-p368-75c4 |
- vllm Vendorvllm-project Affected before 0.32.0 Fixed in 0.32.0 Patch available CNA
- vllm (PyPI) Vendor— Affected before 0.32.0 Fixed in 0.32.0 Patch available GHSA-q97c-p368-75c4
Remediation
Upgrade vLLM to version 0.32.0 on PyPI. Red Hat AI Inference Server, Red Hat Enterprise Linux AI (RHEL AI) 3 and Red Hat OpenShift AI (RHOAI) are affected, and Red Hat gives no plan for them.
Written with Claude Haiku 5.5 from the sources below · 2026-11-02
- Fix · CNA vllm (vllm-project) Fixed in 0.32.0
- Fix · GHSA-q97c-p368-75c4 vllm (PyPI) Fixed in 0.32.0 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat AI Inference Server | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux AI (RHEL AI) 3 | Affected | No fix yet: Fix deferred |
| Red Hat OpenShift AI (RHOAI) | Affected | No fix yet: Fix deferred |
Timeline
- 2026-10-26 Threatist record created from CVE-2026-115916
- 2026-10-27 Affected versions changed · Red Hat
- 2026-10-27 CVSS score added · Red Hat
- 2026-10-27 Priority changed: MEDIUM → LOW
- 2026-10-28 Alias added: GHSA-q97c-p368-75c4
- 2026-10-28 Fix available: PyPI/[email protected] · GHSA-q97c-p368-75c4
- 2026-10-28 CVSS score added · GHSA-q97c-p368-75c4
- 2026-10-28 Weakness changed · GHSA-q97c-p368-75c4
- 2026-10-28 6 new references · GHSA-q97c-p368-75c4
- 2026-11-02 CISA SSVC decision points changed
References
Patch 3
More vllm-project vulnerabilities
- TI-2024-10229 Remote Code Execution in vllm-project/vllm CVSS 3.0CRITICAL 9.8
- TI-2024-08404 Remote Code Execution in vllm-project/vllm CVSS 3.1CRITICAL 9.8
- TI-2026-36017 vLLM: OpenAI auth bypass CVSS 3.1CRITICAL 9.1
- TI-2026-63056 vLLM before 0.28.0 Denial of Service via negative token ID CVSS 4.0HIGH 8.7
- TI-2026-04308 Hardcoded trust_remote_code=True in vllm-project/vllm Bypasses User Security Control CVSS 3.0HIGH 8.8
- TI-2026-39137 vLLM: Remote DoS in vLLM via Invalid Recovered Token Reinjection CVSS 3.1HIGH 7.5
Sources
- CVE-2026-115916 · CVE Program
- CVE-2026-115916 · NVD
- FIRST EPSS
- GHSA-q97c-p368-75c4 · GitHub Advisory Database · CC BY 4.0
- CVE-2026-115916 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences