Permissive default CORS origins in vLLM expose its HTTP server
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Partial Red Hat: 3 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat.
Summary
vLLM before 0.32.0 sets a wildcard default CORS origin on its OpenAI-compatible server (CWE-942). A malicious web page can use a victim's browser to call an unauthenticated server on localhost or an internal network, read the responses and consume GPU resources. Credentials are disabled by default, so cookie-based attacks do not apply.
Written with Claude Haiku 5.5 from the sources below · 2026-10-31
Description from the CNA
vLLM is an inference and serving engine for large language models. Prior to 0.32.0, the OpenAI-compatible server configures Starlette CORSMiddleware with allowed_origins set to a wildcard by default. A malicious web page can use a victim's browser to reach an unauthenticated vLLM server on localhost, an internal network, or a VPN, call endpoints including GET /v1/models and POST /v1/chat/completions, consume GPU resources, and read responses. Cookie-based cross-site request forgery does not apply because credentials are disabled by default, and deployments requiring bearer authentication are exposed only when the caller already has a usable token. This issue is fixed in version 0.32.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| vllm-project | vllm | before 0.32.0 | 0.32.0 | Patch available | CNA |
| — | vllm (PyPI) | before 0.32.0 | 0.32.0 | Patch available | GHSA-vvpg-rrww-wpmh |
- vllm Vendorvllm-project Affected before 0.32.0 Fixed in 0.32.0 Patch available CNA
- vllm (PyPI) Vendor— Affected before 0.32.0 Fixed in 0.32.0 Patch available GHSA-vvpg-rrww-wpmh
Remediation
Upgrade the PyPI package vllm to version 0.32.0 or later. Red Hat lists no available plan for Red Hat AI Inference Server, Red Hat Enterprise Linux AI (RHEL AI) 3 and Red Hat OpenShift AI (RHOAI).
Written with Claude Haiku 5.5 from the sources below · 2026-10-31
- Fix · CNA vllm (vllm-project) Fixed in 0.32.0
- Fix · GHSA-vvpg-rrww-wpmh vllm (PyPI) Fixed in 0.32.0 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat AI Inference Server | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux AI (RHEL AI) 3 | Affected | No fix yet: Fix deferred |
| Red Hat OpenShift AI (RHOAI) | Affected | No fix yet: Fix deferred |
Timeline
- 2026-10-26 Threatist record created from CVE-2026-115917
- 2026-10-27 Affected versions changed · Red Hat
- 2026-10-27 CVSS score added · Red Hat
- 2026-10-28 CVSS score added · NVD
- 2026-10-28 Alias added: GHSA-vvpg-rrww-wpmh
- 2026-10-28 Fix available: PyPI/[email protected] · GHSA-vvpg-rrww-wpmh
- 2026-10-28 CVSS score added · GHSA-vvpg-rrww-wpmh
- 2026-10-28 Weakness changed · GHSA-vvpg-rrww-wpmh
- 2026-10-28 6 new references · GHSA-vvpg-rrww-wpmh
- 2026-10-31 CISA SSVC decision points changed
References
Patch 3
More vllm-project vulnerabilities
- TI-2024-10229 Remote Code Execution in vllm-project/vllm CVSS 3.0CRITICAL 9.8
- TI-2024-08404 Remote Code Execution in vllm-project/vllm CVSS 3.1CRITICAL 9.8
- TI-2026-36017 vLLM: OpenAI auth bypass CVSS 3.1CRITICAL 9.1
- TI-2026-63056 vLLM before 0.28.0 Denial of Service via negative token ID CVSS 4.0HIGH 8.7
- TI-2026-04308 Hardcoded trust_remote_code=True in vllm-project/vllm Bypasses User Security Control CVSS 3.0HIGH 8.8
- TI-2026-39137 vLLM: Remote DoS in vLLM via Invalid Recovered Token Reinjection CVSS 3.1HIGH 7.5
Sources
- CVE-2026-115917 · CVE Program
- CVE-2026-115917 · NVD
- FIRST EPSS
- GHSA-vvpg-rrww-wpmh · GitHub Advisory Database · CC BY 4.0
- CVE-2026-115917 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences