vLLM Responses API bypasses chat template trust setting
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 3 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-400.
Summary
vLLM versions from 0.16.0 before 0.32.0 are affected. The /v1/responses endpoint keeps a caller-supplied chat template when no server template is configured, which bypasses the trust_request_chat_template setting (CWE-400). An authenticated remote attacker with low privileges can exhaust CPU or memory through Jinja template rendering.
Written with Claude Haiku 5.5 from the sources below · 2026-10-30
Description from the CNA
vLLM is an inference and serving engine for large language models. From 0.16.0 until 0.32.0, the /v1/responses endpoint allows an authenticated caller to place an attacker-controlled template in chat_template_kwargs[chat_template] when no server template is configured. ChatParams.get_apply_chat_template_kwargs() preserves that value without enforcing trust_request_chat_template, so the request can bypass the intended trust policy and cause CPU or memory exhaustion through Jinja rendering. This issue is fixed in version 0.32.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| vllm-project | vllm | 0.16.0 to before 0.32.0 | 0.32.0 | Patch available | CNA |
| — | vllm (PyPI) | 0.16.0 to before 0.32.0 | 0.32.0 | Patch available | GHSA-x567-49g5-p4cf |
- vllm Vendorvllm-project Affected 0.16.0 to before 0.32.0 Fixed in 0.32.0 Patch available CNA
- vllm (PyPI) Vendor— Affected 0.16.0 to before 0.32.0 Fixed in 0.32.0 Patch available GHSA-x567-49g5-p4cf
Remediation
Upgrade the vllm package on PyPI to version 0.32.0. Red Hat lists no available plan for Red Hat AI Inference Server, Red Hat Enterprise Linux AI (RHEL AI) 3 and Red Hat OpenShift AI (RHOAI).
Written with Claude Haiku 5.5 from the sources below · 2026-10-30
- Fix · CNA vllm (vllm-project) Fixed in 0.32.0
- Fix · GHSA-x567-49g5-p4cf vllm (PyPI) Fixed in 0.32.0 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat AI Inference Server | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux AI (RHEL AI) 3 | Affected | No fix yet: Fix deferred |
| Red Hat OpenShift AI (RHOAI) | Affected | No fix yet: Fix deferred |
Timeline
- 2026-10-26 Threatist record created from CVE-2026-115918
- 2026-10-27 Affected versions changed · Red Hat
- 2026-10-27 CVSS score added · Red Hat
- 2026-10-27 Priority changed: MEDIUM → LOW
- 2026-10-28 Alias added: GHSA-x567-49g5-p4cf
- 2026-10-28 Fix available: PyPI/[email protected] · GHSA-x567-49g5-p4cf
- 2026-10-28 CVSS score added · GHSA-x567-49g5-p4cf
- 2026-10-28 Weakness changed · GHSA-x567-49g5-p4cf
- 2026-10-28 6 new references · GHSA-x567-49g5-p4cf
- 2026-10-30 CISA SSVC decision points changed
References
Patch 3
More vllm-project vulnerabilities
- TI-2024-10229 Remote Code Execution in vllm-project/vllm CVSS 3.0CRITICAL 9.8
- TI-2024-08404 Remote Code Execution in vllm-project/vllm CVSS 3.1CRITICAL 9.8
- TI-2026-36017 vLLM: OpenAI auth bypass CVSS 3.1CRITICAL 9.1
- TI-2026-63056 vLLM before 0.28.0 Denial of Service via negative token ID CVSS 4.0HIGH 8.7
- TI-2026-04308 Hardcoded trust_remote_code=True in vllm-project/vllm Bypasses User Security Control CVSS 3.0HIGH 8.8
- TI-2026-39137 vLLM: Remote DoS in vLLM via Invalid Recovered Token Reinjection CVSS 3.1HIGH 7.5
Sources
- CVE-2026-115918 · CVE Program
- CVE-2026-115918 · NVD
- FIRST EPSS
- GHSA-x567-49g5-p4cf · GitHub Advisory Database · CC BY 4.0
- CVE-2026-115918 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences