Stored cross-site scripting in Jenkins breadcrumb bar overflow menu
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
Jenkins 2.587 and earlier, and LTS 2.580.1 and earlier, do not escape the text shown in tooltips of breadcrumb bar overflow menu entries. This causes stored cross-site scripting (CWE-79). An attacker with Overall/Read permission can store script that runs when a user interacts with the affected menu.
Written with Claude Haiku 5.5 from the sources below · 2026-11-06
Description from the CNA
Jenkins 2.587 and earlier, LTS 2.580.1 and earlier does not escape the text shown in the tooltips of breadcrumb bar overflow menu entries, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Overall/Read permission.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins | — | 2.588, 2.580.2 | Patch available | CNA |
- Jenkins VendorJenkins Affected — Fixed in 2.588, 2.580.2 Patch available CNA
Remediation
Upgrade Jenkins to version 2.588 or LTS version 2.580.2.
Written with Claude Haiku 5.5 from the sources below · 2026-11-06
- Fix · CNA Jenkins (Jenkins Project) Fixed in 2.588, 2.580.2
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Jenkins — Jenkins Security Advisory 2026-10-28
15 records Highest priority Priority MEDIUM 5 MEDIUM, 10 LOW
Other records, highest priority first
- TI-2026-82060 Path traversal in Jenkins lets attackers overwrite config.xml filesPriority MEDIUM 41
- TI-2026-82068 Deserialization flaw in Jenkins lets attackers inject nested objectsPriority MEDIUM 40
- TI-2026-82064 Jenkins Manage Old Data flaw lets attackers override user accountsPriority MEDIUM 40
Vendor assessments
Timeline
- 2026-10-28 Threatist record created from CVE-2026-117623
- 2026-10-28 Alias added: GHSA-2563-2wcf-c75h
- 2026-11-02 CVSS score added · NVD
- 2026-11-02 Weakness changed · NVD
- 2026-11-05 CVSS score added · CISA ADP
- 2026-11-05 Weakness changed · CISA ADP
- 2026-11-05 CISA SSVC decision points changed
- 2026-11-06 Affected versions changed · Red Hat
- 2026-11-06 CVSS score added · Red Hat
References
Advisory 1
More Jenkins vulnerabilities
- TI-2024-15885 Path traversal in Jenkins KEVCVSS 3.1CRITICAL 9.8
- TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
- TI-2017-14573 Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an… KEVCVSS 3.1CRITICAL 9.8
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2015-04472 The Fingerprints pages in Jenkins before 1.638 and LTS before 1.625.2 might allow remote… KEVCVSS 3.1HIGH 7.5
- TI-2016-07596 The remoting module in Jenkins before 2.32 and LTS before 2.19.3 allows remote attackers… CVSS 3.0CRITICAL 9.8
Sources
- CVE-2026-117623 · CVE Program
- CVE-2026-117623 · NVD
- FIRST EPSS
- GHSA-2563-2wcf-c75h · GitHub Advisory Database · CC BY 4.0
- CVE-2026-117623 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences