Read the docs

Deserialization flaw in Jenkins lets attackers inject nested objects

Priority MEDIUM 40CWE-502Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-502.

Summary

Jenkins 2.587 and earlier, and LTS 2.580.1 and earlier, do not consistently enforce the restriction on deserializing objects of types marked to store their configuration in independent top-level files as nested values. A low-privileged attacker can bypass the root element check and potentially inject nested objects, which is classified as CWE-502.

Written with Claude Haiku 5.5 from the sources below · 2026-11-06

Description from the CNA

Jenkins 2.587 and earlier, LTS 2.580.1 and earlier does not consistently enforce the restriction on deserializing objects of types marked as storing their configuration in independent top-level configuration files as nested values, allowing attackers to bypass the root element check and potentially inject nested objects.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00389 33rd percentileScored 2026-11-07
Fix Fixed Jenkins (Jenkins Project): 2.588, 2.580.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsJenkins—2.588, 2.580.2Patch availableCNA
  • Jenkins VendorJenkins Affected — Fixed in 2.588, 2.580.2 Patch available CNA

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:*before 2.580.2VulnerableJenkins
cpe:2.3:a:jenkins:jenkins:*:*:*:*:-:*:*:*before 2.588VulnerableJenkins
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:* Versions before 2.580.2 Vulnerable ·Jenkins
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:-:*:*:* Versions before 2.588 Vulnerable ·Jenkins

Remediation

Upgrade Jenkins to 2.588 or Jenkins LTS to 2.580.2.

Written with Claude Haiku 5.5 from the sources below · 2026-11-06

  • Fix · CNA Jenkins (Jenkins Project) Fixed in 2.588, 2.580.2

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Advisory ·

    Jenkins — Jenkins Security Advisory 2026-10-28

    15 records Highest priority Priority MEDIUM 5 MEDIUM, 10 LOW

    Other records, highest priority first

    • TI-2026-82060 Path traversal in Jenkins lets attackers overwrite config.xml filesPriority MEDIUM 41
    • TI-2026-82064 Jenkins Manage Old Data flaw lets attackers override user accountsPriority MEDIUM 40
    • TI-2026-82058 Jenkins runs unapproved agent launch commands via Command Agent LauncherPriority MEDIUM 40

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-28 Threatist record created from CVE-2026-117624
  2. 2026-10-28 Alias added: GHSA-xh58-qv89-v6gq
  3. 2026-11-02 CVSS score added · NVD
  4. 2026-11-02 Weakness changed · NVD
  5. 2026-11-05 CVSS score added · CISA ADP
  6. 2026-11-05 Weakness changed · CISA ADP
  7. 2026-11-05 CISA SSVC decision points changed
  8. 2026-11-05 Priority changed: LOW → MEDIUM
  9. 2026-11-06 Affected versions changed · Red Hat
  10. 2026-11-06 CVSS score added · Red Hat

References

  • TI-2024-15885 Path traversal in Jenkins KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
  • TI-2017-14573 Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an… KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
  • TI-2015-04472 The Fingerprints pages in Jenkins before 1.638 and LTS before 1.625.2 might allow remote… KEVCVSS 3.1HIGH 7.5
  • TI-2016-07596 The remoting module in Jenkins before 2.32 and LTS before 2.19.3 allows remote attackers… CVSS 3.0CRITICAL 9.8
See all 293 →

Sources