Read the docs

Stored cross-site scripting in PublishPress Authors WordPress plugin

Priority LOW 28CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · Low
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.

Summary

The PublishPress Authors plugin for WordPress, versions from 0 through 4.17.0, is affected. Improper neutralization of input during web page generation (CWE-79) allows stored cross-site scripting. An attacker with low privileges can store script content, and a victim must interact with the affected page for it to run.

Written with Claude Haiku 5.5 from the sources below · 2026-10-30

Description from the CNA

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in PublishPress PublishPress Authors publishpress-authors allows Stored XSS.This issue affects PublishPress Authors: from n/a through 4.17.0.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00139 3rd percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
PublishPressPublishPress Authorsup to 4.17.0—No fix listedCNA
  • PublishPress Authors VendorPublishPress Affected up to 4.17.0 Fixed in — No fix listed CNA

Remediation

The sources list no fixed version for PublishPress Authors.

Written with Claude Haiku 5.5 from the sources below · 2026-10-30

Timeline

  1. 2026-10-29 Threatist record created from CVE-2026-115610
  2. 2026-10-29 Alias added: GHSA-76qm-2fv3-gv97
  3. 2026-10-30 CISA SSVC decision points changed
  4. 2026-10-30 Priority changed: MEDIUM → LOW

References

  • TI-2022-03111 PublishPress Capabilities < 2.5.2 - Admin+ PHP Objection Injection CVSS 3.1HIGH 7.2
  • TI-2021-07310 PublishPress Capabilities < 2.3.1 - Unauthenticated Arbitrary Options Update to Blog Compromise CVSS 3.1CRITICAL 9.8
  • TI-2026-25067 WordPress PublishPress Revisions plugin <= 3.7.23 - SQL Injection vulnerability CVSS 3.1CRITICAL 9.3
  • TI-2024-08551 Authorization bypass in PublishPress Co-Authors, Multiple Authors and Guest Authors in an… CVSS 3.1HIGH 8.8
  • TI-2026-20427 WordPress PublishPress Authors plugin <= 4.10.1 - Broken Access Control vulnerability CVSS 3.1HIGH 7.5
  • TI-2025-30658 WordPress Gutenberg Blocks <= 3.3.1 - Local File Inclusion Vulnerability CVSS 3.1HIGH 7.5
See all 35 →

Sources