Command injection in OPNsense firmware mirror setting allows root access
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-78.
Summary
OPNsense before 26.7.8 contains a command injection flaw in its firmware mirror setting, tracked as CWE-78. Shell metacharacters stored in a malicious firmware mirror URL are evaluated as commands with root privileges. An authenticated user with the System: Firmware privilege can exploit this through the firmware set API, and can also disable package signature verification through sed injection.
Written with Claude Haiku 5.5 from the sources below · 2026-11-05
Description from the CNA
OPNsense before 26.7.8 contains a command injection vulnerability that allows authenticated users with the System: Firmware privilege to execute commands as root by storing a malicious firmware mirror URL. Attackers can submit shell metacharacters through POST /api/core/firmware/set that opnsense-update evaluates with eval, and can also disable package signature verification through sed injection.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
The core package is fixed in OPNsense 26.7.8.
Written with Claude Haiku 5.5 from the sources below · 2026-11-05
- Fix · CNA core (opnsense) Fixed in 26.7.8
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
opnsense core 26.7.8
3 records Highest priority Priority MEDIUM 1 MEDIUM, 2 LOW
Other records, highest priority first
- TI-2026-83002 Log injection in OPNsense lets attackers lock out victim IP addressesPriority LOW 37
- TI-2026-83003 Configuration line injection in OPNsense wireless WPA settingsPriority LOW 30
Timeline
- 2026-10-30 Threatist record created from CVE-2026-119409
- 2026-10-30 Alias added: GHSA-q3x8-9859-gj9r
- 2026-10-30 CISA SSVC decision points changed
- 2026-10-30 Priority changed: MEDIUM → LOW
- 2026-11-01 Priority changed: LOW → MEDIUM
References
Patch 3
Advisory 2
More opnsense vulnerabilities
- TI-2023-20247 A command injection vulnerability in the component /api/cron/settings/setJob/ of OPNsense… CVSS 3.1CRITICAL 9.8
- TI-2023-20243 Insecure permissions in the configuration directory (/conf/) of OPNsense Community… CVSS 3.1CRITICAL 9.8
- TI-2023-20240 A command injection vulnerability in the component diag_backup.php of OPNsense Community… CVSS 3.1CRITICAL 9.8
- TI-2023-11947 DECISO OPNsense 23.1 does not impose rate limits for authentication, allowing attackers… CVSS 3.1CRITICAL 9.8
- TI-2026-74819 Path traversal in OPNsense GeoIP importer allows root code execution CVSS 3.1CRITICAL 9.9
- TI-2023-20246 /ui/cron/item/open in the Cron component of OPNsense Community Edition before 23.7 and… CVSS 3.1CRITICAL 9.6
Sources
- CVE-2026-119409 · CVE Program
- CVE-2026-119409 · NVD
- FIRST EPSS
- GHSA-q3x8-9859-gj9r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences