Read the docs

Configuration line injection in OPNsense wireless WPA settings

Priority LOW 30CWE-93Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
High
Attack requirements
Present
Impact type
—
Confidentiality · integrity · availability
None · High · High
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA.

Summary

OPNsense core before 26.7.8 contains a configuration line injection flaw in its WPA settings. An authenticated user with wireless-edit privilege can embed CR/LF characters in WPA fields, which injects extra directives. Those directives are loaded by root-run wpa_supplicant and hostapd daemons, letting the attacker alter their configuration.

Written with Claude Haiku 5.5 from the sources below · 2026-11-05

Description from the CNA

OPNsense core before 26.7.8 contains a configuration line injection vulnerability that allows authenticated users with wireless-edit privilege to inject directives by embedding CR/LF characters in WPA fields. Attackers can place newlines in wpa.identity, wpa.passphrase, or RADIUS shared secrets to append arbitrary wpa_supplicant or hostapd directives loaded by root-run daemons.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00424 36th percentileScored 2026-11-07
Fix Fixed core (opnsense): 26.7.8

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
opnsensecorebefore 26.7.826.7.8Patch availableCNA
  • core Vendoropnsense Affected before 26.7.8 Fixed in 26.7.8 Patch available CNA

CPE names Threatist (inferred) · 1

Inferred from how NVD named this product before; not given by a source.

CPEVersionsRoleVendor
cpe:2.3:a:opnsense:opnsense:*:*:*:*:*:*:*:*——opnsense
  • cpe:2.3:a:opnsense:opnsense:*:*:*:*:*:*:*:* Versions — — ·opnsense

Remediation

Update OPNsense core to version 26.7.8 or later, which fixes this issue.

Written with Claude Haiku 5.5 from the sources below · 2026-11-05

  • Fix · CNA core (opnsense) Fixed in 26.7.8

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    opnsense core 26.7.8

    3 records Highest priority Priority MEDIUM 1 MEDIUM, 2 LOW

    Other records, highest priority first

    • TI-2026-82992 Command injection in OPNsense firmware mirror setting allows root accessPriority MEDIUM 44
    • TI-2026-83002 Log injection in OPNsense lets attackers lock out victim IP addressesPriority LOW 37

Timeline

  1. 2026-10-30 Threatist record created from CVE-2026-119424
  2. 2026-10-30 Alias added: GHSA-r639-jmpp-wf8p
  3. 2026-11-01 Priority changed: MEDIUM → LOW
  4. 2026-11-05 CISA SSVC decision points changed

References

  • TI-2023-20247 A command injection vulnerability in the component /api/cron/settings/setJob/ of OPNsense… CVSS 3.1CRITICAL 9.8
  • TI-2023-20243 Insecure permissions in the configuration directory (/conf/) of OPNsense Community… CVSS 3.1CRITICAL 9.8
  • TI-2023-20240 A command injection vulnerability in the component diag_backup.php of OPNsense Community… CVSS 3.1CRITICAL 9.8
  • TI-2023-11947 DECISO OPNsense 23.1 does not impose rate limits for authentication, allowing attackers… CVSS 3.1CRITICAL 9.8
  • TI-2026-74819 Path traversal in OPNsense GeoIP importer allows root code execution CVSS 3.1CRITICAL 9.9
  • TI-2023-20246 /ui/cron/item/open in the Cron component of OPNsense Community Edition before 23.7 and… CVSS 3.1CRITICAL 9.6
See all 54 →

Sources