Unsafe deserialization in OpenSearch SQL plugin allows code execution
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-502.
Summary
The OpenSearch SQL plugin (opensearch-project sql) is affected from 2.8.0.0 before 2.19.6.0 and from 3.0.0.0-alpha1 before 3.7.0.0. Unsafe deserialization of untrusted data in the cursor parameter of the plugins/sql endpoint lets the server deserialize attacker-supplied objects (CWE-502). A remote authenticated user with basic read and search permissions can supply a crafted cursor parameter to execute arbitrary code on the server.
Written with Claude Haiku 5.5 from the sources below · 2026-11-02
Description from the CNA
OpenSearch SQL supports querying OpenSearch data using SQL and Piped Processing Language. In the 2.x line from 2.8.0.0 until 2.19.6.0, and the 3.x line prior to 3.7.0.0, a remote authenticated user with basic read/search permissions can provide a crafted `cursor` parameter to the `plugins/sql` endpoint and trigger unsafe deserialization of untrusted data, resulting in arbitrary code execution on the server. This issue is fixed in repository releases 2.19.6.0 and 3.7.0.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
Upgrade the OpenSearch SQL plugin to 2.19.6.0 for the 2.x line or to 3.7.0.0 for the 3.x line, the repository releases that fix this issue.
Written with Claude Haiku 5.5 from the sources below · 2026-11-02
- Fix · CNA sql (opensearch-project) Fixed in 2.19.6.0, 3.7.0.0
Timeline
- 2026-10-30 Threatist record created from CVE-2026-63393
- 2026-11-01 Priority changed: MEDIUM → LOW
- 2026-11-02 CISA SSVC decision points changed
- 2026-11-02 Priority changed: LOW → MEDIUM
References
Other 7
- https://github.com/opensearch-project/sql/security/advisories/GHSA-r8cv-xvqm-4qj4
- https://github.com/opensearch-project/sql/pull/5469
- https://github.com/opensearch-project/sql/pull/5572
- https://github.com/opensearch-project/sql/commit/402a284f1dff3545236480b67f860aa93fb667de
- https://github.com/opensearch-project/sql/commit/9ab50384d3ad571a14211415fba2f6d26d4c80db
- https://github.com/opensearch-project/sql/releases/tag/2.19.6.0
- https://github.com/opensearch-project/sql/releases/tag/3.7.0.0
More AWS vulnerabilities
- TI-2026-23989 crypto: algif_aead - Revert to operating out-of-place KEVCVSS 3.1HIGH 7.8
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2024-18648 Amazon AWS Amplify CLI before 12.10.1 incorrectly configures the role trust policy of IAM… CVSS 3.1CRITICAL 9.8
- TI-2024-05929 Openssh: regresshion - race condition in ssh allows rce/dos CVSS 3.1HIGH 8.1
- TI-2025-03847 Input validation issue in AWS Amplify Studio UI component properties CVSS 4.0CRITICAL 9.0
- TI-2026-11603 HTTP/2 Stream Parser Confusion Body-Inspection Bypass in Amazon CloudFront with AWS WAF CVSS 4.0HIGH 7.9
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences