Stored cross-site scripting in PublishPress Authors WordPress plugin
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The PublishPress Authors plugin for WordPress is affected through 4.17.0. The name field mapped to display_name is stored without sanitization and output without escaping, causing cross-site scripting (CWE-79). An authenticated attacker with subscriber access or above can store scripts that run when users open affected pages. Exploitation requires the attacker's account to have a mapped author term, which is not present by default for new users on a stock install.
Written with Claude Haiku 5.5 from the sources below · 2026-11-05
Description from the CNA
The Co-Authors, Multiple Authors and Guest Authors in an Author Box with PublishPress Authors plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'name (maps to display_name)' parameter in all versions up to, and including, 4.17.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Exploitation requires the attacker's user account to have a mapped author term, which occurs when an administrator has assigned them as a co-author on content or has enabled automatic author term creation for their role — this mapping is not present by default for new users on a stock install.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| PublishPress | Co-Authors, Multiple Authors and Guest Authors in an Author Box with PublishPress Authors | up to 4.17.0 | — | No fix listed | CNA |
- Co-Authors, Multiple Authors and Guest Authors in an Author Box with PublishPress Authors VendorPublishPress Affected up to 4.17.0 Fixed in — No fix listed CNA
Remediation
No fixed version is listed for Co-Authors, Multiple Authors and Guest Authors in an Author Box with PublishPress Authors.
Written with Claude Haiku 5.5 from the sources below · 2026-11-05
Timeline
- 2026-10-31 Threatist record created from CVE-2026-111592
- 2026-10-31 Alias added: GHSA-6x99-gc47-w4j4
- 2026-11-01 Priority changed: MEDIUM → LOW
- 2026-11-01 CISA SSVC decision points changed
References
Other 5
- https://www.wordfence.com/threat-intel/vulnerabilities/id/329226bc-7d0e-45e0-8ac0-656517e0e4ca?source=cve
- https://plugins.trac.wordpress.org/browser/publishpress-authors/tags/4.17.0/src/core/Classes/Author_Editor.php#L86
- https://plugins.trac.wordpress.org/browser/publishpress-authors/tags/4.17.0/src/modules/multiple-authors/multiple-authors.php#L5233
- https://plugins.trac.wordpress.org/browser/publishpress-authors/tags/4.17.0/src/modules/multiple-authors/multiple-authors.php#L302
- https://plugins.trac.wordpress.org/browser/publishpress-authors/tags/4.18.0/src/core/Classes/Author_Editor.php
More PublishPress vulnerabilities
- TI-2022-03111 PublishPress Capabilities < 2.5.2 - Admin+ PHP Objection Injection CVSS 3.1HIGH 7.2
- TI-2021-07310 PublishPress Capabilities < 2.3.1 - Unauthenticated Arbitrary Options Update to Blog Compromise CVSS 3.1CRITICAL 9.8
- TI-2026-25067 WordPress PublishPress Revisions plugin <= 3.7.23 - SQL Injection vulnerability CVSS 3.1CRITICAL 9.3
- TI-2024-08551 Authorization bypass in PublishPress Co-Authors, Multiple Authors and Guest Authors in an… CVSS 3.1HIGH 8.8
- TI-2026-20427 WordPress PublishPress Authors plugin <= 4.10.1 - Broken Access Control vulnerability CVSS 3.1HIGH 7.5
- TI-2025-30658 WordPress Gutenberg Blocks <= 3.3.1 - Local File Inclusion Vulnerability CVSS 3.1HIGH 7.5
Sources
- CVE-2026-111592 · CVE Program
- CVE-2026-111592 · NVD
- FIRST EPSS
- GHSA-6x99-gc47-w4j4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences