Read the docs
TI-2026-84476 Aliases CVE-2026-121652

Stored cross-site scripting in AWS Amplify maplibre-gl-js-amplify popups

Priority LOW 22CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Active
Attack complexity
Low
Attack requirements
None
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-79.

Summary

AWS Amplify maplibre-gl-js-amplify before 4.0.3 contains a stored cross-site scripting flaw (CWE-79) in which input is not neutralized before it is rendered on a web page. A remote authenticated user with low privileges can inject arbitrary web script or HTML through the title, address, or place_name property of GeoJSON feature data rendered by popupRender, or through the geofenceId value rendered in AmplifyGeofenceControl. User interaction is required.

Written with Claude Haiku 5.5 from the sources below · 2026-11-03

Description from the CNA

Cross-site scripting (XSS) issue in AWS Amplify maplibre-gl-js-amplify before 4.0.3 might allow remote authenticated users to inject arbitrary web script or HTML via the (1) title, (2) address, or (3) place_name property in GeoJSON feature data rendered by popupRender, or the (4) geofenceId value rendered in AmplifyGeofenceControl. To remediate this issue, users should upgrade to 4.0.3 or later.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00264 18th percentileScored 2026-11-07
Fix Fixed maplibre-gl-js-amplify (AWS): 4.0.3

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
AWSmaplibre-gl-js-amplifybefore 4.0.34.0.3Patch availableCNA
  • maplibre-gl-js-amplify VendorAWS Affected before 4.0.3 Fixed in 4.0.3 Patch available CNA

Remediation

Upgrade maplibre-gl-js-amplify to version 4.0.3 or later.

Written with Claude Haiku 5.5 from the sources below · 2026-11-03

  • Fix · CNA maplibre-gl-js-amplify (AWS) Fixed in 4.0.3

Timeline

  1. 2026-11-03 Threatist record created from CVE-2026-121652
  2. 2026-11-03 CISA SSVC decision points changed

References

  • TI-2026-23989 crypto: algif_aead - Revert to operating out-of-place KEVCVSS 3.1HIGH 7.8
  • TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
  • TI-2024-18648 Amazon AWS Amplify CLI before 12.10.1 incorrectly configures the role trust policy of IAM… CVSS 3.1CRITICAL 9.8
  • TI-2024-05929 Openssh: regresshion - race condition in ssh allows rce/dos CVSS 3.1HIGH 8.1
  • TI-2025-03847 Input validation issue in AWS Amplify Studio UI component properties CVSS 4.0CRITICAL 9.0
  • TI-2026-11603 HTTP/2 Stream Parser Confusion Body-Inspection Bypass in Amazon CloudFront with AWS WAF CVSS 4.0HIGH 7.9
See all 383 →

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences