Incorrect authorization in GetPaid WordPress plugin REST API
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · High · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-863.
Summary
The GetPaid plugin for WordPress before 2.8.63 contains an incorrect authorization flaw (CWE-863) in its REST posts controller, which maps REST operations to generic WordPress post capabilities instead of the plugin's manage_invoicing permission. Authenticated users with lower-privileged roles such as Editor or Author can list other users' invoices, mark pending invoices as paid without recording payment transactions, or create published items and new invoices through the REST API. The CVSS 4.0 vector requires low privileges and no user interaction.
Written with Claude Haiku 5.5 from the sources below · 2026-11-04
Description from the CNA
The GetPaid plugin for WordPress before 2.8.63 contains an incorrect authorization vulnerability where the check_post_permissions() method in includes/api/class-getpaid-rest-posts-controller.php maps REST operations to generic WordPress post capabilities instead of enforcing the plugin's manage_invoicing permission. Authenticated users with lower-privileged roles such as Editor or Author can exploit this flaw to list other users' invoices, mark pending invoices as paid without recording payment transactions, or create published items and new invoices through the REST API.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| AyeCode Ltd | Payment forms, Buy now buttons, and Invoicing System | GetPaid | before 2.8.63 | 2.8.63 | Patch available | CNA |
- Payment forms, Buy now buttons, and Invoicing System | GetPaid VendorAyeCode Ltd Affected before 2.8.63 Fixed in 2.8.63 Patch available CNA
Remediation
Update the GetPaid plugin to version 2.8.63 or later, which fixes the flaw. The sources list no advisory identifier for this fix.
Written with Claude Haiku 5.5 from the sources below · 2026-11-04
- Fix · CNA Payment forms, Buy now buttons, and Invoicing System | GetPaid (AyeCode Ltd) Fixed in 2.8.63
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
AyeCode Payment forms, Buy now buttons, and Invoicing System | GetPaid 2.8.63
3 records Highest priority Priority MEDIUM 1 MEDIUM, 2 LOW
Other records, highest priority first
- TI-2026-85113 Negative quantity bypasses payment in GetPaid WordPress pluginPriority MEDIUM 44
- TI-2026-85112 Authorization bypass in GetPaid WordPress plugin exposes invoicesPriority LOW 36
Timeline
- 2026-11-04 Threatist record created from CVE-2026-119747
- 2026-11-04 Alias added: GHSA-jf75-578j-f2xq
- 2026-11-04 CISA SSVC decision points changed
- 2026-11-04 Priority changed: MEDIUM → LOW
References
Patch 1
More AyeCode Ltd vulnerabilities
- TI-2024-28816 WordPress GeoDirectory plugin <= 2.3.61 - SQL Injection vulnerability CVSS 3.1HIGH 8.8
- TI-2024-06008 UsersWP < 1.2.12 - Users Information Disclosure CVSS 3.1HIGH 7.5
- TI-2022-04371 GeoDirectory < 2.2.22 - Contributor+ Stored XSS via Shortcode CVSS 3.1MEDIUM 5.4
- TI-2025-05608 GeoDirectory < 2.8.120 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.9
- TI-2024-05812 SQL injection in stiofansisland UsersWP – Front-end login form, User Registration, User… CVSS 3.1CRITICAL 9.8
- TI-2021-06653 GeoDirectory Location Manager < 2.1.0.10 - Multiple Unauthenticated SQL Injections CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-119747 · CVE Program
- CVE-2026-119747 · NVD
- FIRST EPSS
- GHSA-jf75-578j-f2xq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences