Missing authorization in PublishPress Revisions plugin for WordPress
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-862.
Summary
PublishPress Revisions through 4.2.0, a WordPress plugin from PublishPress, is affected. A missing authorization check (CWE-862) lets users reach functionality that their access control settings should block. An authenticated attacker with low privileges can affect data integrity over the network.
Written with Claude Haiku 5.5 from the sources below · 2026-11-07
Description from the CNA
Missing Authorization vulnerability in PublishPress PublishPress Revisions revisionary allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects PublishPress Revisions: from n/a through 4.2.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| PublishPress | PublishPress Revisions | up to 4.2.0 | — | No fix listed | CNA |
- PublishPress Revisions VendorPublishPress Affected up to 4.2.0 Fixed in — No fix listed CNA
Remediation
The sources list no fixed version for PublishPress Revisions.
Written with Claude Haiku 5.5 from the sources below · 2026-11-07
Timeline
- 2026-11-06 Threatist record created from CVE-2026-120851
- 2026-11-07 Alias added: GHSA-55xc-f9h7-8xfr
- 2026-11-07 CISA SSVC decision points changed
More PublishPress vulnerabilities
- TI-2022-03111 PublishPress Capabilities < 2.5.2 - Admin+ PHP Objection Injection CVSS 3.1HIGH 7.2
- TI-2021-07310 PublishPress Capabilities < 2.3.1 - Unauthenticated Arbitrary Options Update to Blog Compromise CVSS 3.1CRITICAL 9.8
- TI-2026-25067 WordPress PublishPress Revisions plugin <= 3.7.23 - SQL Injection vulnerability CVSS 3.1CRITICAL 9.3
- TI-2024-08551 Authorization bypass in PublishPress Co-Authors, Multiple Authors and Guest Authors in an… CVSS 3.1HIGH 8.8
- TI-2026-20427 WordPress PublishPress Authors plugin <= 4.10.1 - Broken Access Control vulnerability CVSS 3.1HIGH 7.5
- TI-2025-30658 WordPress Gutenberg Blocks <= 3.3.1 - Local File Inclusion Vulnerability CVSS 3.1HIGH 7.5
Sources
- CVE-2026-120851 · CVE Program
- CVE-2026-120851 · NVD
- FIRST EPSS
- GHSA-55xc-f9h7-8xfr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences