Authentication bypass in OpenAM SAML login accepts unsigned assertions
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-290.
Summary
OpenAM before 16.1.4 has an authentication bypass in its SAML v2.0 service provider, which accepts unsigned assertions on the ECP (PAOS) and HTTP-Artifact bindings when WantAssertionsSigned is false. Unauthenticated remote attackers can submit forged assertions to obtain sessions as any mapped user, including administrators, and hijack single sign-on to dependent applications. The flaw is classified as CWE-290.
Written with Claude Haiku 5.5 from the sources below · 2026-11-08
Description from the CNA
OpenAM before 16.1.4 contains an authentication bypass vulnerability in its SAML v2.0 service provider that accepts unsigned assertions on the ECP (PAOS) and HTTP-Artifact bindings when WantAssertionsSigned is false. Unauthenticated remote attackers can submit forged assertions to obtain sessions as any mapped user, including administrators, and hijack single sign-on to dependent applications.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| OpenIdentityPlatform | OpenAM | before 16.1.4 | 16.1.4 | Patch available | CNA |
| OpenIdentityPlatform | OpenAM | before 16.1.4 | 16.1.4 | Patch available | CNA |
- OpenAM VendorOpenIdentityPlatform Affected before 16.1.4 Fixed in 16.1.4 Patch available CNA
- OpenAM VendorOpenIdentityPlatform Affected before 16.1.4 Fixed in 16.1.4 Patch available CNA
Remediation
Upgrade OpenIdentityPlatform OpenAM to version 16.1.4 or later, which fixes the flaw.
Written with Claude Haiku 5.5 from the sources below · 2026-11-08
- Fix · CNA OpenAM (OpenIdentityPlatform) Fixed in 16.1.4
- Fix · CNA OpenAM (OpenIdentityPlatform) Fixed in 16.1.4
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
OpenIdentityPlatform OpenAM 16.1.4
18 records Highest priority Priority MEDIUM 10 MEDIUM, 8 LOW
Other records, highest priority first
- TI-2026-86693 Session token disclosure in OpenAM notification WebSocketPriority MEDIUM 58
- TI-2026-86691 Privilege escalation in OpenAM via self-registration attribute bypassPriority MEDIUM 55
- TI-2026-86685 Unbounded Java deserialization in OpenAM enables denial of servicePriority MEDIUM 53
Timeline
- 2026-11-08 Threatist record created from CVE-2026-123550
- 2026-11-08 Alias added: GHSA-f9mm-fxrq-6c5v
References
More OpenIdentityPlatform vulnerabilities
- TI-2025-20332 OpenDJ Denial of Service (Dos) using alias loop CVSS 4.0HIGH 8.7
- TI-2026-25836 Pre-Authentication Remote Code Execution via `jato.clientSession` Deserialization in OpenAM CVSS 4.0CRITICAL 9.3
- TI-2026-86693 Session token disclosure in OpenAM notification WebSocket CVSS 4.0CRITICAL 10.0
- TI-2026-86691 Privilege escalation in OpenAM via self-registration attribute bypass CVSS 4.0CRITICAL 9.3
- TI-2026-86685 Unbounded Java deserialization in OpenAM enables denial of service CVSS 4.0HIGH 8.7
- TI-2026-44519 OpenAM: Unauthenticated Remote Code Execution via Class.forName in AuthXMLUtils.createCustomCallback CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-123550 · CVE Program
- CVE-2026-123550 · NVD
- GHSA-f9mm-fxrq-6c5v · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences