Session token disclosure in OpenAM notification WebSocket
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-201.
Summary
OpenIdentityPlatform OpenAM from 14.0.0 before 16.1.4 contains an information disclosure flaw (CWE-201) that exposes live session tokens through the notification WebSocket. An unauthenticated remote attacker can bypass the agent-only check through an unvalidated internal forward on legacy Liberty ID-FF endpoints and collect iPlanetDirectoryPro tokens. The stolen tokens allow the attacker to hijack user and administrator sessions.
Written with Claude Haiku 5.5 from the sources below · 2026-11-08
Description from the CNA
OpenAM from 14.0.0 before 16.1.4 contains an information disclosure vulnerability that allows unauthenticated attackers to read live session tokens from the notification WebSocket. Attackers can bypass the agent-only check through an unvalidated internal forward on legacy Liberty ID-FF endpoints, collecting iPlanetDirectoryPro tokens to hijack user and administrator sessions.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| OpenIdentityPlatform | OpenAM | 14.0.0 to before 16.1.4 | 16.1.4 | Patch available | CNA |
| OpenIdentityPlatform | OpenAM | 14.0.0 to before 16.1.4 | 16.1.4 | Patch available | CNA |
| OpenIdentityPlatform | OpenAM | 14.0.0 to before 16.1.4 | 16.1.4 | Patch available | CNA |
- OpenAM VendorOpenIdentityPlatform Affected 14.0.0 to before 16.1.4 Fixed in 16.1.4 Patch available CNA
- OpenAM VendorOpenIdentityPlatform Affected 14.0.0 to before 16.1.4 Fixed in 16.1.4 Patch available CNA
- OpenAM VendorOpenIdentityPlatform Affected 14.0.0 to before 16.1.4 Fixed in 16.1.4 Patch available CNA
Remediation
Upgrade OpenIdentityPlatform OpenAM to 16.1.4, which fixes this flaw.
Written with Claude Haiku 5.5 from the sources below · 2026-11-08
- Fix · CNA OpenAM (OpenIdentityPlatform) Fixed in 16.1.4
- Fix · CNA OpenAM (OpenIdentityPlatform) Fixed in 16.1.4
- Fix · CNA OpenAM (OpenIdentityPlatform) Fixed in 16.1.4
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
OpenIdentityPlatform OpenAM 16.1.4
18 records Highest priority Priority MEDIUM 10 MEDIUM, 8 LOW
Other records, highest priority first
- TI-2026-86692 Authentication bypass in OpenAM SAML login accepts unsigned assertionsPriority MEDIUM 55
- TI-2026-86691 Privilege escalation in OpenAM via self-registration attribute bypassPriority MEDIUM 55
- TI-2026-86685 Unbounded Java deserialization in OpenAM enables denial of servicePriority MEDIUM 53
Timeline
- 2026-11-08 Threatist record created from CVE-2026-123551
- 2026-11-08 Alias added: GHSA-hv5h-fgcg-pwgf
References
More OpenIdentityPlatform vulnerabilities
- TI-2025-20332 OpenDJ Denial of Service (Dos) using alias loop CVSS 4.0HIGH 8.7
- TI-2026-25836 Pre-Authentication Remote Code Execution via `jato.clientSession` Deserialization in OpenAM CVSS 4.0CRITICAL 9.3
- TI-2026-86692 Authentication bypass in OpenAM SAML login accepts unsigned assertions CVSS 4.0CRITICAL 9.3
- TI-2026-86691 Privilege escalation in OpenAM via self-registration attribute bypass CVSS 4.0CRITICAL 9.3
- TI-2026-86685 Unbounded Java deserialization in OpenAM enables denial of service CVSS 4.0HIGH 8.7
- TI-2026-44519 OpenAM: Unauthenticated Remote Code Execution via Class.forName in AuthXMLUtils.createCustomCallback CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-123551 · CVE Program
- CVE-2026-123551 · NVD
- GHSA-hv5h-fgcg-pwgf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences