Read the docs

Vulnerabilities

Filters

Reset all
Threatist priority
Signals
Fix status
Impact type
Attack vector
Requirements
Product

Products as named in CPE, with their records.

Published
Weakness (CWE)
2 selected

7 records

Priority MEDIUM 55

The Autoptimize WordPress plugin before 3.1.7 does not sanitise and escape the settings imported from a previous export, allowing high privileged users (such as an administrator) to inject arbitrary javascript into the a…

CVSS 3.1MEDIUM 4.8 Network High privileges User interaction EPSS 0.0047 Published 2023-05-30 Fixed in 3.1.7
Priority LOW 23

The Autoptimize WordPress plugin before 3.1.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltere…

CVSS 3.1MEDIUM 4.8 Network High privileges User interaction EPSS 0.00644 Published 2022-09-16 Fixed in 3.1.1 CWE-79
Priority LOW 23

The Autoptimize WordPress plugin before 2.7.8 does not check for malicious files such as .html in the archive uploaded via the 'Import Settings' feature.

CVSS 3.1MEDIUM 4.8 Network High privileges User interaction EPSS 0.00617 Published 2021-06-21 Fixed in 2.7.8 CWE-79
Priority LOW 38

The Autoptimize WordPress plugin before 2.7.8 attempts to remove potential malicious files from the extracted archive uploaded via the 'Import Settings' feature, however this is not sufficient to protect against RCE as a…

CVSS 3.1HIGH 8.1 Network No auth No interaction EPSS 0.01183 Published 2021-06-21 Fixed in 2.7.8 CWE-362
Priority MEDIUM 48

The Autoptimize WordPress plugin before 2.7.8 attempts to delete malicious files (such as .php) form the uploaded archive via the "Import Settings" feature, after its extraction.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.03727 Published 2021-06-21 Fixed in 2.7.8 CWE-434
Priority LOW 23

The Autoptimize WordPress plugin before 2.8.4 was missing proper escaping and sanitisation in some of its settings, allowing high privilege users to set XSS payloads in them, leading to stored Cross-Site Scripting issues

CVSS 3.1MEDIUM 4.8 Network High privileges User interaction EPSS 0.00626 Published 2021-05-24 Fixed in 2.8.4 CWE-79
Priority MEDIUM 46

The ao_ccss_import AJAX call in Autoptimize Wordpress Plugin 2.7.6 does not ensure that the file provided is a legitimate Zip file, allowing high privilege users to upload arbitrary files, such as PHP, leading to remote…

CVSS 3.1HIGH 7.2 Network High privileges No interaction EPSS 0.13139 Published 2020-09-03 No fix listed CWE-434