Read the docs

Vulnerabilities

Filters

Reset all
Threatist priority
Signals
Fix status
Impact type
Attack vector
Requirements
Product

Products as named in CPE, with their records.

Published
Weakness (CWE)
2 selected

24 records

TI-2022-08542 CVE-2022-24728 · GHSA-4fc4-4p5g-6w89

Cross-site Scripting in CKEditor4

Priority LOW 27

CKEditor4 is an open source what-you-see-is-what-you-get HTML editor.

CVSS 3.1MEDIUM 5.4 Network Low privileges User interaction EPSS 0.01203 Published 2022-03-16 Fixed in 4.18.0 CWE-79
Priority LOW 27

ckeditor is an open source WYSIWYG HTML editor with rich content support.

CVSS 3.1MEDIUM 5.4 Network Low privileges User interaction EPSS 0.01188 Published 2021-08-12 Fixed in 4.16.2 CWE-94
Priority LOW 33

A cross-site scripting (XSS) vulnerability in the HTML Data Processor in CKEditor 4 4.14.0 through 4.16.x before 4.16.1 allows remote attackers to inject executable JavaScript code through a crafted comment because --!>…

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.03189 Published 2021-06-09 Fixed in 4.16.1, 7.80 +3 CWE-79
Priority LOW 33

It was possible to execute a ReDoS-type attack inside CKEditor 4 before 4.16 by persuading a victim to paste crafted URL-like text into the editor, and then press Enter or Space (in the Autolink plugin).

CVSS 3.1MEDIUM 6.5 Network No auth User interaction EPSS 0.0235 Published 2021-01-26 Fixed in 4.16.0 CWE-829
Priority LOW 33

It was possible to execute a ReDoS-type attack inside CKEditor 4 before 4.16 by persuading a victim to paste crafted text into the Styles input of specific dialogs (in the Advanced Tab for Dialogs plugin).

CVSS 3.1MEDIUM 6.5 Network No auth User interaction EPSS 0.01994 Published 2021-01-26 Fixed in 4.16 CWE-829
Priority LOW 31

A cross-site scripting (XSS) vulnerability in the Color Dialog plugin for CKEditor 4.15.0 allows remote attackers to run arbitrary web script after persuading a user to copy and paste crafted HTML code into one of editor…

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.0205 Published 2020-11-12 Fixed in 4.15.1 CWE-79
Priority LOW 30

A cross-site scripting (XSS) vulnerability in the WSC plugin through 5.5.7.5 for CKEditor 4 allows remote attackers to run arbitrary web script inside an IFRAME element by injecting a crafted HTML element into the editor…

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.0131 Published 2020-03-10 No fix listed CWE-79
Priority LOW 34

A cross-site scripting (XSS) vulnerability in the HTML Data Processor for CKEditor 4.0 before 4.14 allows remote attackers to inject arbitrary web script through a crafted "protected" comment (with the cke_protected synt…

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.04308 Published 2020-03-07 Fixed in 4.14.0 CWE-79
Priority LOW 36

hook_file_download in the CKEditor module 7.x-1.4 for Drupal does not properly restrict access to private files, which allows remote attackers to read private files via a direct request.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.01744 Published 2019-11-13 No fix listed CWE-200