Read the docs

Vulnerabilities

Filters

Reset all
Threatist priority
Signals
Fix status
Impact type
Attack vector
Requirements
Product

Products as named in CPE, with their records.

Published
Weakness (CWE)
2 selected

40 records

Priority HIGH 66

CodeIgniter is a PHP full-stack web framework A vulnerability was found in the Language class that allowed DoS attacks.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.00773 Published 2024-03-29 Fixed in 4.4.7 CWE-835
TI-2022-19429 CVE-2022-40835 · GHSA-6646-39mj-h9x4

B.C.

Priority MEDIUM 44

B.C. Institute of Technology CodeIgniter <=3.1.13 is vulnerable to SQL Injection via system\database\DB_query_builder.php.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.01091 Published 2022-10-07 No fix listed CWE-89
TI-2022-19428 CVE-2022-40834 · GHSA-qg28-mpvr-p3rx

B.C.

Priority MEDIUM 44

B.C. Institute of Technology CodeIgniter <=3.1.13 is vulnerable to SQL Injection via system\database\DB_query_builder.php or_not_like() function.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.01091 Published 2022-10-07 No fix listed CWE-89
TI-2022-19427 CVE-2022-40833 · GHSA-7x5f-444r-jc46

B.C.

Priority MEDIUM 44

B.C. Institute of Technology CodeIgniter <=3.1.13 is vulnerable to SQL Injection via system\database\DB_query_builder.php or_where_in() function.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.01091 Published 2022-10-07 No fix listed CWE-89
TI-2022-19426 CVE-2022-40832 · GHSA-hj3j-f78g-wj29

B.C.

Priority MEDIUM 44

B.C. Institute of Technology CodeIgniter <=3.1.13 is vulnerable to SQL Injection via system\database\DB_query_builder.php having() function.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.01091 Published 2022-10-07 No fix listed CWE-89
TI-2022-19425 CVE-2022-40831 · GHSA-2m9w-pj9w-w243

B.C.

Priority MEDIUM 44

B.C. Institute of Technology CodeIgniter <=3.1.13 is vulnerable to SQL Injection via system\database\DB_query_builder.php like() function.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.01091 Published 2022-10-07 No fix listed CWE-89
TI-2022-19424 CVE-2022-40830 · GHSA-8vpr-6j25-gxcc

B.C.

Priority MEDIUM 51

B.C. Institute of Technology CodeIgniter <=3.1.13 is vulnerable to SQL Injection via system\database\DB_query_builder.php where_not_in() function.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.01091 Published 2022-10-07 No fix listed CWE-89
TI-2022-19423 CVE-2022-40829 · GHSA-8j68-m69v-7x9f

B.C.

Priority MEDIUM 51

B.C. Institute of Technology CodeIgniter <=3.1.13 is vulnerable to SQL Injection via system\database\DB_query_builder.php or_like() function.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.01091 Published 2022-10-07 No fix listed CWE-89
TI-2022-19422 CVE-2022-40828 · GHSA-3mpc-949c-h3m6

B.C.

Priority MEDIUM 51

B.C. Institute of Technology CodeIgniter <=3.1.13 is vulnerable to SQL Injection via system\database\DB_query_builder.php or_where_not_in() function.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.01091 Published 2022-10-07 No fix listed CWE-89
TI-2022-19421 CVE-2022-40827 · GHSA-jv9q-9872-3fqh

B.C.

Priority MEDIUM 51

B.C. Institute of Technology CodeIgniter <=3.1.13 is vulnerable to SQL Injection via system\database\DB_query_builder.php where() function.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.01042 Published 2022-10-07 No fix listed CWE-89
TI-2022-19420 CVE-2022-40826 · GHSA-cjcg-hc25-x29f

B.C.

Priority MEDIUM 51

B.C. Institute of Technology CodeIgniter <=3.1.13 is vulnerable to SQL Injection via system\database\DB_query_builder.php or_having() function.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.01091 Published 2022-10-07 No fix listed CWE-89
TI-2022-19419 CVE-2022-40825 · GHSA-vx2g-v3f9-m6mw

B.C.

Priority MEDIUM 44

B.C. Institute of Technology CodeIgniter <=3.1.13 is vulnerable to SQL Injection via system\database\DB_query_builder.php where_in() function.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.01091 Published 2022-10-07 No fix listed CWE-89
TI-2022-19418 CVE-2022-40824 · GHSA-6x3c-285p-52r4

B.C.

Priority MEDIUM 51

B.C. Institute of Technology CodeIgniter <=3.1.13 is vulnerable to SQL Injection via system\database\DB_query_builder.php or_where() function.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.01091 Published 2022-10-07 No fix listed CWE-89
Priority LOW 29

CodeIgniter4 is the 4.x branch of CodeIgniter, a PHP full-stack web framework.

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.01002 Published 2022-01-24 Fixed in 4.1.8 CWE-79
Load more