CodeIgniter4 Language class DoS Vulnerability
Priority HIGH 66CWE-835Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-835.
Summary
CodeIgniter is a PHP full-stack web framework A vulnerability was found in the Language class that allowed DoS attacks. This vulnerability can be exploited by an attacker to consume a large amount of memory on the server. Upgrade to v4.4.7 or later.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00773 55th percentileScored 2026-11-07
Fix Fixed CodeIgniter4 (codeigniter4): 4.4.7codeigniter4/framework (Packagist): 4.4.7
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| codeigniter4 | CodeIgniter4 | before 4.4.7 | 4.4.7 | Patch available | CNA |
| — | codeigniter4/framework (Packagist) | before 4.4.7 | 4.4.7 | Patch available | GHSA-39fp-mqmm-gxj6 |
- CodeIgniter4 Vendorcodeigniter4 Affected before 4.4.7 Fixed in 4.4.7 Patch available CNA
- codeigniter4/framework (Packagist) Vendor— Affected before 4.4.7 Fixed in 4.4.7 Patch available GHSA-39fp-mqmm-gxj6
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:codeigniter:codeigniter:*:*:*:*:*:*:*:* | before 4.4.7 | Vulnerable | codeigniter4 |
- cpe:2.3:a:codeigniter:codeigniter:*:*:*:*:*:*:*:* Versions before 4.4.7 Vulnerable ·codeigniter4
Remediation
- Fix · CNA CodeIgniter4 (codeigniter4) Fixed in 4.4.7
- Fix · GHSA-39fp-mqmm-gxj6 codeigniter4/framework (Packagist) Fixed in 4.4.7 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-29904
- 2026-10-03 Alias added: GHSA-39fp-mqmm-gxj6
References
More codeigniter4 Codeigniter vulnerabilities
- TI-2014-07135 CodeIgniter before 3.0 and Kohana 3.2.3 and earlier and 3.3.x through 3.3.2 make it… CVSS 3.0CRITICAL 9.8
- TI-2022-16370 SameSite may allow cross-site request forgery (CSRF) protection to be bypassed CVSS 3.1HIGH 8.8
- TI-2022-06025 Deserialization of Untrusted Data in Codeigniter4 CVSS 3.1CRITICAL 9.8
- TI-2024-27591 A Cross-Site Request Forgery (CSRF) in Codeigniter 3.1.13 allows attackers to arbitrarily… CVSS 3.1HIGH 7.5
- TI-2014-07136 CodeIgniter before 2.2.0 makes it easier for attackers to decode session cookies by… CVSS 3.0CRITICAL 9.8
- TI-2022-18660 Secure or HttpOnly flag set in Config\Cookie is not reflected in Cookies issued in Codeigniter4 CVSS 3.1MEDIUM 4.3
Sources
- CVE-2024-29904 · CVE Program
- CVE-2024-29904 · NVD
- FIRST EPSS
- GHSA-39fp-mqmm-gxj6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences