Remote Code Execution Vulnerability in Validation Placeholders
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
CodeIgniter is a PHP full-stack web framework. This vulnerability allows attackers to execute arbitrary code when you use Validation Placeholders. The vulnerability exists in the Validation library, and validation methods in the controller and in-model validation are also vulnerable because they use the Validation library internally. This issue is patched in version 4.3.5.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| codeigniter4 | CodeIgniter4 | before 4.3.5 | 4.3.5 | Patch available | CNA |
| — | codeigniter4/framework (Packagist) | before 4.3.5 | 4.3.5 | Patch available | GHSA-m6m8-6gq8-c9fj |
- CodeIgniter4 Vendorcodeigniter4 Affected before 4.3.5 Fixed in 4.3.5 Patch available CNA
- codeigniter4/framework (Packagist) Vendor— Affected before 4.3.5 Fixed in 4.3.5 Patch available GHSA-m6m8-6gq8-c9fj
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:codeigniter:codeigniter:*:*:*:*:*:*:*:* | before 4.3.5 | Vulnerable | codeigniter4 |
- cpe:2.3:a:codeigniter:codeigniter:*:*:*:*:*:*:*:* Versions before 4.3.5 Vulnerable ·codeigniter4
Remediation
- Fix · CNA CodeIgniter4 (codeigniter4) Fixed in 4.3.5
- Fix · GHSA-m6m8-6gq8-c9fj codeigniter4/framework (Packagist) Fixed in 4.3.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-32692
- 2026-10-03 Alias added: GHSA-m6m8-6gq8-c9fj
References
Advisory 2
More codeigniter4 Codeigniter vulnerabilities
- TI-2014-07135 CodeIgniter before 3.0 and Kohana 3.2.3 and earlier and 3.3.x through 3.3.2 make it… CVSS 3.0CRITICAL 9.8
- TI-2022-16370 SameSite may allow cross-site request forgery (CSRF) protection to be bypassed CVSS 3.1HIGH 8.8
- TI-2022-06025 Deserialization of Untrusted Data in Codeigniter4 CVSS 3.1CRITICAL 9.8
- TI-2024-27591 A Cross-Site Request Forgery (CSRF) in Codeigniter 3.1.13 allows attackers to arbitrarily… CVSS 3.1HIGH 7.5
- TI-2014-07136 CodeIgniter before 2.2.0 makes it easier for attackers to decode session cookies by… CVSS 3.0CRITICAL 9.8
- TI-2024-19671 CodeIgniter4 Language class DoS Vulnerability CVSS 3.1HIGH 7.5
Sources
- CVE-2023-32692 · CVE Program
- CVE-2023-32692 · NVD
- FIRST EPSS
- GHSA-m6m8-6gq8-c9fj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences