Read the docs

Vulnerabilities

Filters

Reset all
Threatist priority
Signals
Fix status
Impact type
Attack vector
Requirements
Product

Products as named in CPE, with their records.

Published
Weakness (CWE)
2 selected

3 records

Priority MEDIUM 45

Plataformatec Devise version 4.5.0 and earlier, using the lockable module contains a CWE-367 vulnerability in The `Devise::Models::Lockable` class, more specifically at the `#increment_failed_attempts` method.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.01556 Published 2019-04-03 Fixed in 4.6.0 CWE-367
Priority MEDIUM 45

Devise gem 2.2.x before 2.2.3, 2.1.x before 2.1.3, 2.0.x before 2.0.5, and 1.5.x before 1.5.4 for Ruby, when using certain databases, does not properly perform type conversion when performing database queries, which migh…

CVSS 2.0MEDIUM 6.8 Network No auth Interaction — EPSS 0.14126 Published 2013-04-25 Fixed in 2.2.3, 2.1.3 +2 CWE-399