Read the docs

Vulnerabilities

Filters

Reset all
Threatist priority
Signals
Fix status
Impact type
Attack vector
Requirements
Product

Products as named in CPE, with their records.

Published
Weakness (CWE)
2 selected

45 records

Priority MEDIUM 55

The LearnPress WordPress plugin before 4.2.7.5.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfilt…

CVSS 3.1MEDIUM 4.8 Network High privileges User interaction EPSS 0.00355 Published 2025-05-15 Fixed in 4.2.7.5.1 CWE-79
Priority MEDIUM 55

The LearnPress WordPress plugin before 4.2.7.5.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfilt…

CVSS 3.1MEDIUM 4.8 Network High privileges User interaction EPSS 0.00326 Published 2025-05-15 Fixed in 4.2.7.5.1 CWE-79
Priority LOW 28

The LearnPress – WordPress LMS Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting in all versions up to, and including, 4.2.7.5 due to insufficient input sanitization and output escaping of a lesson…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.00314 Published 2025-01-25 No fix listed CWE-79
TI-2024-09167 CVE-2024-9881 · GHSA-p9v3-8f7q-wffx

LearnPress < 4.2.7.2 - Admin+ Stored XSS

Priority MEDIUM 55

The LearnPress WordPress plugin before 4.2.7.2 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfilter…

CVSS 3.1MEDIUM 4.8 Network High privileges User interaction EPSS 0.0038 Published 2024-12-12 Fixed in 4.2.7.2 CWE-79
TI-2024-09290 CVE-2024-10010 · GHSA-jx47-v2mx-xmc3

LearnPress < 4.2.7.2 - Admin+ Stored XSS

Priority MEDIUM 55

The LearnPress WordPress plugin before 4.2.7.2 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfilter…

CVSS 3.1MEDIUM 4.8 Network High privileges User interaction EPSS 0.00462 Published 2024-12-12 Fixed in 4.2.7.2 CWE-79
Priority HIGH 84

The LearnPress – WordPress LMS Plugin plugin for WordPress is vulnerable to SQL Injection via the 'c_only_fields' parameter of the /wp-json/learnpress/v1/courses REST API endpoint in all versions up to, and including, 4.…

CVSS 3.1CRITICAL 10.0 Network No auth No interaction EPSS 0.62882 Published 2024-09-12 No fix listed CWE-89
Priority MEDIUM 63

The LearnPress – WordPress LMS Plugin plugin for WordPress is vulnerable to SQL Injection via the 'c_fields' parameter of the /wp-json/lp/v1/courses/archive-course REST API endpoint in all versions up to, and including,…

CVSS 3.1CRITICAL 10.0 Network No auth No interaction EPSS 0.12056 Published 2024-09-12 No fix listed CWE-89
Priority MEDIUM 41

The LearnPress – WordPress LMS Plugin plugin for WordPress is vulnerable to time-based SQL Injection via the 'order' parameter in all versions up to, and including, 4.2.6.9.3 due to insufficient escaping on the user supp…

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.00618 Published 2024-08-08 No fix listed CWE-89
Priority MEDIUM 42

The LearnPress – WordPress LMS Plugin plugin for WordPress is vulnerable to Local File Inclusion in all versions up to, and including, 4.2.6.8.2 via the 'render_content_block_template' function.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.00814 Published 2024-07-25 No fix listed CWE-98
Priority LOW 31

The LearnPress – WordPress LMS Plugin plugin for WordPress is vulnerable to unauthorized user registration due to a missing capability check on the 'register' function in all versions up to, and including, 4.2.6.8.1.

CVSS 3.1MEDIUM 5.3 Network No auth No interaction EPSS 0.00615 Published 2024-07-02 No fix listed CWE-862
Priority LOW 26

The LearnPress – WordPress LMS Plugin plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 4.2.6.8 due to incorrect implementation of get_items_permissions_check func…

CVSS 3.1MEDIUM 5.3 Network No auth No interaction EPSS 0.01008 Published 2024-06-05 No fix listed CWE-200
Priority LOW 28

The LearnPress – WordPress LMS Plugin plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘id’ parameter in all versions up to, and including, 4.2.6.6 due to insufficient input sanitization and o…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.00295 Published 2024-05-22 No fix listed CWE-79
Priority LOW 28

The LearnPress – WordPress LMS Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘layout_html’ parameter in all versions up to, and including, 4.2.6.5 due to insufficient input sanitization…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.0034 Published 2024-05-10 No fix listed CWE-79
Priority HIGH 75

The LearnPress – WordPress LMS Plugin plugin for WordPress is vulnerable to time-based SQL Injection via the ‘term_id’ parameter in versions up to, and including, 4.2.6.5 due to insufficient escaping on the user supplied…

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.36925 Published 2024-05-10 No fix listed CWE-89
Priority MEDIUM 42

The LearnPress – WordPress LMS Plugin plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the 'save_post_materials' function in versions up to, and including, 4.2.6.5.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.01025 Published 2024-05-09 No fix listed CWE-434
Priority LOW 34

The LearnPress – WordPress LMS Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the _id value in all versions up to, and including, 4.2.6.4 due to insufficient input sanitization and output es…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.0032 Published 2024-04-19 No fix listed CWE-79
Priority LOW 22

The LearnPress – WordPress LMS Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Course, Lesson, and Quiz title and content in all versions up to, and including, 4.2.6.3 due to insufficient…

CVSS 3.1MEDIUM 4.8 Network High privileges User interaction EPSS 0.00422 Published 2024-04-09 No fix listed CWE-79
Priority LOW 29

The LearnPress – WordPress LMS Plugin plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 4.2.6.3 due to missing validation on a user controlled key when looking u…

CVSS 3.1MEDIUM 6.5 Network No auth No interaction EPSS 0.00388 Published 2024-04-09 No fix listed CWE-285
Load more