LearnPress – WordPress LMS Plugin < 4.2.7.5.1 - Admin+ Stored XSS
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The LearnPress WordPress plugin before 4.2.7.5.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | LearnPress | before 4.2.7.5.1 | 4.2.7.5.1 | Patch available | CNA |
- LearnPress VendorUnknown Affected before 4.2.7.5.1 Fixed in 4.2.7.5.1 Patch available CNA
Remediation
- Fix · CNA LearnPress (Unknown) Fixed in 4.2.7.5.1
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
LearnPress 4.2.7.5.1
2 records Highest priority Priority MEDIUM 2 MEDIUM
Other records, highest priority first
- TI-2024-12176 LearnPress – WordPress LMS Plugin < 4.2.7.5.1 - Admin+ Stored XSSPriority MEDIUM 55
Timeline
- 2026-10-02 Threatist record created from CVE-2024-13127
- 2026-10-03 Alias added: GHSA-3262-4hm9-mq8q
References
More ThimPress Learnpress vulnerabilities
- TI-2024-07900 LearnPress – WordPress LMS Plugin <= 4.2.7 - Unauthenticated SQL Injection via 'c_only_fields' CVSS 3.1CRITICAL 10.0
- TI-2023-06018 LearnPress <= 4.2.5.7 - Unauthenticated SQL Injection via order_by CVSS 3.1CRITICAL 9.8
- TI-2024-04124 LearnPress – WordPress LMS Plugin <= 4.2.6.5 - Unauthenticated Time-Based SQL Injection CVSS 3.1CRITICAL 9.8
- TI-2023-18355 WordPress LearnPress plugin <= 4.2.3 - Authenticated Broken Access Control vulnerability CVSS 3.1HIGH 8.8
- TI-2022-03105 LearnPress < 4.1.7.2 - Unauthenticated PHP Object Injection via REST API CVSS 3.1HIGH 8.1
- TI-2020-04911 LearnPress Wordpress plugin version prior and including 3.2.6.7 is vulnerable to SQL Injection CVSS 3.1HIGH 8.8
Sources
- CVE-2024-13127 · CVE Program
- CVE-2024-13127 · NVD
- FIRST EPSS
- GHSA-3262-4hm9-mq8q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences