Read the docs

Vulnerabilities

Filters

Reset all
Threatist priority
Signals
Fix status
Impact type
Attack vector
Requirements
Product

Products as named in CPE, with their records.

Published
Weakness (CWE)
2 selected

11 records

Priority LOW 35

An allocation of resources without limits vulnerability in the HTTP handler component of Google mcp-toolbox versions up to and including 1.4.0 allows an unauthenticated attacker to cause a denial of service (DoS).

CVSS 4.0MEDIUM 6.6 Network No auth No interaction EPSS 0.00238 Published 2026-07-31 No fix listed CWE-770
Priority LOW 25

An improper authorization and security-boundary bypass vulnerability in the bigquery-execute-sql tool component of Google mcp-toolbox versions 0.16.1 through 1.4.0 allows an authenticated attacker to bypass allowedDatase…

CVSS 4.0MEDIUM 5.7 Network Low privileges No interaction EPSS 0.00204 Published 2026-07-31 No fix listed CWE-285
Priority MEDIUM 43

Incorrect Authorization in the direct HTTP API tool invocation endpoint in Google mcp-toolbox versions v1.3.0 and v1.4.0 allows an unauthenticated attacker to invoke tools protected by the scopeRequired feature via sendi…

CVSS 4.0HIGH 8.1 Network No auth No interaction EPSS 0.00252 Published 2026-07-31 No fix listed CWE-863
Priority LOW 26

A Server-Side Request Forgery (SSRF) and credential exfiltration vulnerability exists in the cloud-healthcare-fhir-fetch-page tool of googleapis/mcp-toolbox.

CVSS 4.0MEDIUM 6.0 Network Low privileges No interaction EPSS 0.00193 Published 2026-07-27 No fix listed CWE-918
Priority LOW 39

A SQL injection (CWE-89) and security boundary bypass (CWE-863) vulnerability exists in the prebuilt BigQuery forecasting tool (bigquery-forecast) of googleapis/mcp-toolbox.

CVSS 4.0HIGH 8.6 Network Low privileges No interaction EPSS 0.00197 Published 2026-07-21 No fix listed CWE-863
Priority LOW 38

An authenticated authorization bypass vulnerability exists in MCP Toolbox for Databases due to missing scope enforcement across older protocol handlers.

CVSS 4.0HIGH 8.6 Network Low privileges No interaction EPSS 0.00145 Published 2026-06-18 Fixed in 1.4.0 CWE-862
Priority MEDIUM 47

An authentication bypass vulnerability exists in the generic opaque token validation path (validateOpaqueToken) of googleapis/mcp-toolbox.

CVSS 4.0CRITICAL 9.3 Network No auth No interaction EPSS 0.00185 Published 2026-06-18 Fixed in 1.4.0 CWE-287
Priority MEDIUM 47

An authentication bypass vulnerability exists in the generic opaque token validation path (validateOpaqueToken) of googleapis/mcp-toolbox.

CVSS 4.0CRITICAL 9.3 Network No auth No interaction EPSS 0.00176 Published 2026-06-18 Fixed in 1.4.0 CWE-287