Priority LOW 30
The Ninja Forms WordPress plugin before 3.13.3 allows unauthenticated attackers to generate valid access tokens via the REST API which can then be used to read form submissions.
CVSS 3.1MEDIUM 5.3· Network · No auth · No interaction · EPSS 0.00347 · Published 2026-01-02 · Fixed in 3.13.3
Priority LOW 39
The Ninja Forms – The Contact Form Builder That Grows With You plugin for WordPress is vulnerable to Insecure Direct Object Reference in versions up to, and including, 3.13.2.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.00442 · Published 2025-12-17 · No fix listed CWE-639
Priority LOW 24
The Ninja Forms – The Contact Form Builder That Grows With You plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 3.12.0.
CVSS 3.1MEDIUM 5.4· Network · No auth · User interaction · EPSS 0.00162 · Published 2025-09-27 · No fix listed CWE-352
Priority LOW 19
The Ninja Forms – The Contact Form Builder That Grows With You plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 3.12.0.
CVSS 3.1MEDIUM 4.3· Network · No auth · User interaction · EPSS 0.00162 · Published 2025-09-27 · No fix listed CWE-352
Priority HIGH 82
The Ninja Forms WordPress plugin before 3.11.1 unserializes user input via form field, which could allow Unauthenticated users to perform PHP Object Injection when a suitable gadget is present on the blog.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.00541 · Published 2025-09-18 · Fixed in 3.11.1 CWE-502
Priority LOW 28
The Ninja Forms – The Contact Form Builder That Grows With You plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the use of a templating engine in all versions up to, and including, 3.10.2.1 due to in…
CVSS 3.1MEDIUM 6.4· Network · Low privileges · No interaction · EPSS 0.00246 · Published 2025-06-27 · No fix listed CWE-79
Priority MEDIUM 55
The Ninja Forms WordPress plugin before 3.10.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfilter…
CVSS 3.1MEDIUM 4.8· Network · High privileges · User interaction · EPSS 0.0026 · Published 2025-05-19 · Fixed in 3.10.1 CWE-79
Priority MEDIUM 55
The Ninja Forms WordPress plugin before 3.10.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfilter…
CVSS 3.1MEDIUM 4.8· Network · High privileges · User interaction · EPSS 0.0026 · Published 2025-05-19 · Fixed in 3.10.1 CWE-79
Priority MEDIUM 55
The Ninja Forms WordPress plugin before 3.10.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfilter…
CVSS 3.1MEDIUM 4.8· Network · High privileges · User interaction · EPSS 0.00311 · Published 2025-05-19 · Fixed in 3.10.1 CWE-79
Priority LOW 28
The Ninja Forms – The Contact Form Builder That Grows With You plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's shortcode in all versions up to, and including, 3.8.24 due to insufficient…
CVSS 3.1MEDIUM 6.4· Network · Low privileges · No interaction · EPSS 0.00316 · Published 2025-01-30 · No fix listed CWE-79
Priority LOW 29
The The Ninja Forms – The Contact Form Builder That Grows With You plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 3.8.22.
CVSS 3.1MEDIUM 6.3· Network · Low privileges · No interaction · EPSS 0.00494 · Published 2024-12-29 · No fix listed CWE-94
Priority LOW 38
The Ninja Forms – The Contact Form Builder That Grows With You plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the calculations parameter in all versions up to, and including, 3.8.19 due to insuffic…
CVSS 3.1HIGH 7.2· Network · No auth · No interaction · EPSS 0.0032 · Published 2024-12-12 · No fix listed CWE-79
Priority LOW 27
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Kevin Stover Ninja Forms ninja-forms allows Stored XSS.This issue affects Ninja Forms: from n/a through <= 3.8.16.
CVSS 3.1MEDIUM 5.9· Network · High privileges · User interaction · EPSS 0.00413 · Published 2024-11-19 · No fix listed CWE-79
Priority LOW 27
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Kevin Stover Ninja Forms ninja-forms allows Stored XSS.This issue affects Ninja Forms: from n/a through <= 3.8.16.
CVSS 3.1MEDIUM 5.9· Network · High privileges · User interaction · EPSS 0.00413 · Published 2024-11-19 · No fix listed CWE-79
Priority LOW 27
The Ninja Forms Contact Form plugin for WordPress is vulnerable to Reflected Self-Based Cross-Site Scripting via the 'Referer' header in all versions up to, and including, 3.8.15 due to insufficient input sanitization an…
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00291 · Published 2024-09-25 · No fix listed CWE-79
Priority LOW 26
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Saturday Drive Ninja Forms allows Stored XSS.This issue affects Ninja Forms: from n/a through 3.8.11.
CVSS 3.1MEDIUM 5.9· Network · High privileges · User interaction · EPSS 0.00312 · Published 2024-09-17 · No fix listed CWE-79
Priority MEDIUM 60
The Ninja Forms WordPress plugin before 3.8.11 does not escape an URL before outputting it back in an attribute, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00702 · Published 2024-09-02 · Fixed in 3.8.11 CWE-79
Priority LOW 37
Cross-Site Request Forgery (CSRF) vulnerability in Saturday Drive Ninja Forms allows Cross Site Request Forgery.This issue affects Ninja Forms: from n/a through 3.8.6.
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.00201 · Published 2024-08-26 · No fix listed CWE-352
Priority MEDIUM 42
Improper Control of Generation of Code ('Code Injection') vulnerability in Saturday Drive Ninja Forms allows Code Injection.This issue affects Ninja Forms: from n/a through 3.8.4.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.00467 · Published 2024-07-09 · No fix listed CWE-94
Priority HIGH 71
Missing Authorization vulnerability in Saturday Drive Ninja Forms.This issue affects Ninja Forms: from n/a through 3.6.25.
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.00536 · Published 2024-06-19 · No fix listed CWE-862
Priority MEDIUM 43
Missing Authorization vulnerability in Saturday Drive Ninja Forms.This issue affects Ninja Forms: from n/a through 3.6.25.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.00499 · Published 2024-06-19 · No fix listed CWE-862
Priority LOW 33
Improper Input Validation vulnerability in Saturday Drive Ninja Forms Contact Form.This issue affects Ninja Forms Contact Form : from n/a through 3.6.24.
CVSS 3.1HIGH 7.2· Network · High privileges · No interaction · EPSS 0.00601 · Published 2024-04-17 · No fix listed CWE-20
Priority MEDIUM 40
Cross-site request forgery (CSRF) vulnerability exists in Ninja Forms prior to 3.4.31.
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.00311 · Published 2024-04-11 · Fixed in 3.4.31 CWE-352
Priority LOW 25
Ninja Forms prior to 3.8.1 contains a cross-site scripting vulnerability in submit processing.
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.00532 · Published 2024-04-11 · Fixed in 3.8.1 CWE-79
Priority LOW 28
Ninja Forms prior to 3.8.1 contains a cross-site scripting vulnerability in custom fields for labels.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00454 · Published 2024-04-11 · Fixed in 3.8.1 CWE-79
Load more