Read the docs

Vulnerabilities

Filters

Reset all
Threatist priority
Signals
Fix status
Impact type
Attack vector
Requirements
Product

Products as named in CPE, with their records.

Published
Weakness (CWE)
2 selected

3 records

TI-2022-08252 CVE-2022-24375 · GHSA-vh4f-fgpp-x8x2

Denial of service (DoS) in node-opcua

Priority LOW 36

The package node-opcua before 2.74.0 are vulnerable to Denial of Service (DoS) when bypassing the limitations for excessive memory consumption by sending multiple CloseSession requests with the deleteSubscription paramet…

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.01671 Published 2022-08-24 Fixed in 2.74.0 CWE-400
TI-2022-05601 CVE-2022-21208 · GHSA-4hr4-pjjh-2q2w

Denial of service (DoS) in node-opcua

Priority LOW 36

The package node-opcua before 2.74.0 are vulnerable to Denial of Service (DoS) due to a missing limitation on the number of received chunks - per single session or in total for all concurrent sessions.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.01461 Published 2022-08-23 Fixed in 2.74.0 CWE-1284
TI-2022-08944 CVE-2022-25231 · GHSA-qpgc-xh7j-52q8

Denial of service (DoS) in node-opcua

Priority LOW 36

The package node-opcua before 2.74.0 are vulnerable to Denial of Service (DoS) by sending a specifically crafted OPC UA message with a special OPC UA NodeID, when the requested memory allocation exceeds the v8’s memory l…

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.01321 Published 2022-08-23 Fixed in 2.74.0 CWE-770