Priority CRITICAL 100KEV
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 19.2 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 that, under certain conditions, could have allowed an unauthenticated user to exec…
CVSS 3.1CRITICAL 10.0· Network · No auth · No interaction · EPSS 0.6522 · Published 2026-10-13 · Partial fix · 19.2.8, 19.3.5 +1 CWE-190
Priority LOW 38
An issue was discovered in Ruby 4 before 4.0.5.
CVSS 3.1HIGH 8.1· Network · No auth · No interaction · EPSS 0.00478 · Published 2026-05-22 · Fixed in 4.0.5 CWE-362
Priority LOW 35
A ReDoS issue was discovered in the Time component through 0.2.1 in Ruby through 3.2.1.
CVSS 3.1MEDIUM 5.3· Network · No auth · No interaction · EPSS 0.02452 · Published 2023-03-31 · Partial fix · 0.2.2, 0.1.1 CWE-1333
Priority MEDIUM 43
The cgi gem before 0.1.0.2, 0.2.x before 0.2.2, and 0.3.x before 0.3.5 for Ruby allows HTTP response splitting.
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.02452 · Published 2022-11-18 · Partial fix · 0.3.5, 0.2.2 +1 CWE-74
Priority MEDIUM 40
There is a buffer over-read in Ruby before 2.6.10, 2.7.x before 2.7.6, 3.x before 3.0.4, and 3.1.x before 3.1.2.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.0437 · Published 2022-05-09 · Partial fix CWE-125
Priority MEDIUM 48
A double free was found in the Regexp compiler in Ruby 3.x before 3.0.4 and 3.1.x before 3.1.2.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.03138 · Published 2022-05-09 · Fixed CWE-415
Priority LOW 39
CGI::Cookie.parse in Ruby through 2.6.8 mishandles security prefixes in cookie names.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.03151 · Published 2022-01-01 · Partial fix · 0.3.1, 0.2.1 +1 CWE-565
Priority LOW 39
Date.parse in the date gem through 3.2.0 for Ruby allows ReDoS (regular expression Denial of Service) via a long string.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.03463 · Published 2022-01-01 · Partial fix · 3.2.1, 3.1.2 +2 CWE-1333
Priority LOW 38
An issue was discovered in Ruby through 2.6.7, 2.7.x through 2.7.3, and 3.x through 3.0.1.
CVSS 3.1HIGH 7.4· Network · No auth · No interaction · EPSS 0.02909 · Published 2021-08-01 · Partial fix CWE-755
Priority HIGH 67
In Ruby through 3.0 on Windows, a remote attacker can submit a crafted path when a Web application handles a parameter with TmpDir.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.58039 · Published 2021-07-27 · Fixed in 0.1.2 CWE-22
Priority LOW 32
An issue was discovered in Ruby through 2.6.7, 2.7.x through 2.7.3, and 3.x through 3.0.1.
CVSS 3.1MEDIUM 5.8· Network · No auth · No interaction · EPSS 0.0305 · Published 2021-07-13 · Partial fix
Priority MEDIUM 41
The REXML gem before 3.2.5 in Ruby before 2.6.7, 2.7.x before 2.7.3, and 3.x before 3.0.1 does not properly address XML round-trip issues.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.05061 · Published 2021-04-21 · Partial fix · 3.2.5 CWE-115
Priority LOW 39
An issue was discovered in Ruby through 2.5.8, 2.6.x through 2.6.6, and 2.7.x through 2.7.1.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.03818 · Published 2020-10-06 · Partial fix · 1.6.1, 1.5.1 +1 CWE-444
Priority LOW 29
An issue was discovered in Ruby 2.5.x through 2.5.7, 2.6.x through 2.6.5, and 2.7.0.
CVSS 3.1MEDIUM 5.3· Network · No auth · No interaction · EPSS 0.02525 · Published 2020-05-04 · Fixed CWE-908
Priority LOW 38
In Puma (RubyGem) before 4.3.2 and before 3.12.3, if an application using Puma allows untrusted input in a response header, an attacker can use newline characters (i.e.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.02549 · Published 2020-02-28 · Partial fix · 3.12.3, 4.3.2 +2 CWE-113
Priority MEDIUM 50
An exploitable heap overflow vulnerability exists in the Psych::Emitter start_document function of Ruby.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.04741 · Published 2020-02-14 · Will not fix CWE-787
Priority LOW 32
verify_certificate_identity in the OpenSSL extension in Ruby before 2.0.0 patchlevel 645, 2.1.x before 2.1.6, and 2.2.x before 2.2.2 does not properly validate hostnames, which allows remote attackers to spoof servers vi…
CVSS 3.1MEDIUM 5.9· Network · No auth · No interaction · EPSS 0.02815 · Published 2019-11-29 · Partial fix · 2.1.6 CWE-20
Priority LOW 35
Ruby through 2.4.7, 2.5.x through 2.5.6, and 2.6.x through 2.6.4 mishandles path checking within File.fnmatch functions.
CVSS 3.1MEDIUM 6.5· Network · No auth · No interaction · EPSS 0.03289 · Published 2019-11-26 · Partial fix
Priority MEDIUM 47
The OpenSSL extension of Ruby (Git trunk) versions after 2011-09-01 up to 2011-11-03 always generated an exponent value of '1' to be used for private RSA key generation.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.02529 · Published 2019-11-26 · No fix listed CWE-326
Priority LOW 27
Various methods in WEBrick::HTTPRequest in Ruby 1.9.2 and 1.8.7 and earlier do not validate the X-Forwarded-For, X-Forwarded-Host and X-Forwarded-Server headers in requests, which might allow remote attackers to inject a…
CVSS 3.1MEDIUM 5.3· Network · No auth · No interaction · EPSS 0.01521 · Published 2019-11-26 · No fix listed CWE-74
Priority MEDIUM 42
Ruby through 2.4.7, 2.5.x through 2.5.6, and 2.6.x through 2.6.4 allows code injection if the first argument (aka the "command" argument) to Shell#[] or Shell#test in lib/shell.rb is untrusted data.
CVSS 3.1HIGH 8.1· Network · No auth · No interaction · EPSS 0.04187 · Published 2019-11-26 · Partial fix CWE-94
Priority LOW 31
Ruby through 2.4.7, 2.5.x through 2.5.6, and 2.6.x through 2.6.4 allows HTTP Response Splitting.
CVSS 3.1MEDIUM 5.3· Network · No auth · No interaction · EPSS 0.04569 · Published 2019-11-26 · Partial fix CWE-74
Priority MEDIUM 41
WEBrick::HTTPAuth::DigestAuth in Ruby through 2.4.7, 2.5.x through 2.5.6, and 2.6.x through 2.6.4 has a regular expression Denial of Service cause by looping/backtracking.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.05086 · Published 2019-11-26 · Partial fix CWE-287
Priority MEDIUM 46
An issue was discovered in Ruby before 2.3.8, 2.4.x before 2.4.5, 2.5.x before 2.5.2, and 2.6.x before 2.6.0-preview3.
CVSS 3.0HIGH 8.1· Network · No auth · No interaction · EPSS 0.07968 · Published 2018-11-16 · Partial fix
Priority MEDIUM 55
An issue was discovered in the OpenSSL library in Ruby before 2.3.8, 2.4.x before 2.4.5, 2.5.x before 2.5.2, and 2.6.x before 2.6.0-preview3.
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.10715 · Published 2018-11-16 · Partial fix · 2.0.9, 2.1.2
Load more