Priority MEDIUM 55
The WP Maps WordPress plugin before 4.7.2 does not sanitise and escape some of its Map settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltere…
CVSS 3.1MEDIUM 4.8· Network · High privileges · User interaction · EPSS 0.00272 · Published 2025-05-01 · Fixed in 4.7.2 CWE-79
Priority MEDIUM 55
The WP Maps WordPress plugin before 4.7.2 does not sanitise and escape some of its Map settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltere…
CVSS 3.1MEDIUM 4.8· Network · High privileges · User interaction · EPSS 0.00294 · Published 2025-05-01 · Fixed in 4.7.2 CWE-79
Priority MEDIUM 55
The WP Maps WordPress plugin before 4.7.2 does not sanitise and escape some of its Map settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltere…
CVSS 3.1MEDIUM 4.8· Network · High privileges · User interaction · EPSS 0.00314 · Published 2025-05-01 · Fixed in 4.7.2 CWE-79
Priority MEDIUM 40
Cross-Site Request Forgery (CSRF) vulnerability in flippercode WordPress Plugin for Google Maps – WP MAPS (formerly WP Google Map Plugin) plugin <= 4.4.2 versions.
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.00301 · Published 2023-11-12 · No fix listed CWE-352
Priority LOW 27
Auth. (editor+) Stored Cross-Site Scripting (XSS) vulnerability in flippercode WordPress Plugin for Google Maps – WP MAPS plugin <= 4.3.9 versions.
CVSS 3.1MEDIUM 5.9· Network · High privileges · User interaction · EPSS 0.0038 · Published 2023-04-04 · No fix listed CWE-79
Priority LOW 39
Cross-Site Request Forgery (CSRF) vulnerability affecting Delete Marker Category, Delete Map, and Copy Map functions in WP Google Map plugin (versions <= 4.2.3).
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.00568 · Published 2022-03-11 · No fix listed CWE-352
Priority LOW 23
The WP Google Map WordPress plugin before 1.7.7 did not sanitise or escape the Map Title before outputting them in the page, leading to a Stored Cross-Site Scripting issue by high privilege users, even when the unfiltere…
CVSS 3.1MEDIUM 4.8· Network · High privileges · User interaction · EPSS 0.00668 · Published 2021-08-09 · Fixed in 1.7.7 CWE-79
Priority LOW 35
Unvalidated input in the WP Google Map Plugin WordPress plugin, versions before 4.1.5, in the Manage Locations page within the plugin settings was vulnerable to SQL Injection through a high privileged user (admin+).
CVSS 3.1HIGH 7.2· Network · High privileges · No interaction · EPSS 0.01416 · Published 2021-03-18 · Fixed in 4.1.5 CWE-89
Priority LOW 39
The wp-google-map-plugin plugin before 2.3.10 for WordPress has CSRF in the add/edit location feature.
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.00699 · Published 2019-08-14 · No fix listed CWE-352
Priority LOW 39
The wp-google-map-plugin plugin before 2.3.10 for WordPress has CSRF in the add/edit map feature.
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.00699 · Published 2019-08-14 · No fix listed CWE-352
Priority LOW 39
The wp-google-map-plugin plugin before 2.3.10 for WordPress has CSRF in the add/edit category feature.
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.00699 · Published 2019-08-14 · No fix listed CWE-352
Priority LOW 29
The wp-google-map-plugin plugin before 3.1.2 for WordPress has XSS.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00978 · Published 2019-08-12 · No fix listed CWE-79
Priority LOW 29
The wp-google-map-plugin plugin before 2.3.7 for WordPress has XSS related to the add_query_arg() and remove_query_arg() functions.
CVSS 3.0MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.01 · Published 2019-08-12 · No fix listed CWE-79