Read the docs

Vulnerabilities

Filters

Reset all
Threatist priority
Signals
Fix status
Impact type
Attack vector
Requirements
Product

Products as named in CPE, with their records.

Published
Weakness (CWE)
1 selected

40 records

Priority MEDIUM 47

@better-auth/expo before 1.7.16 allows certain account-takeover outcomes (e.g., unauthenticated changes of any account's email address), because it signs a caller-supplied state value without checking whether that value…

CVSS 3.1CRITICAL 9.1 Network No auth No interaction EPSS 0.00203 Published 2026-11-04 Fixed in 1.7.16 CWE-346
Priority MEDIUM 41

Better Auth from 1.5.0-beta.12 before 1.7.7 contains an authentication bypass vulnerability in the OAuth Proxy plugin that allows unauthenticated attackers to sign in as other users by forging encrypted profiles.

CVSS 4.0CRITICAL 9.1 Network No auth No interaction EPSS 0.00288 Published 2026-10-14 Fixed in 1.7.7 CWE-287
Priority LOW 39

Better Auth @better-auth/sso from 1.7.0-rc.2 before 1.7.3 contains an authentication bypass vulnerability that allows authenticated users to sign in as other users by registering a personal SSO provider.

CVSS 4.0HIGH 8.6 Network Low privileges No interaction EPSS 0.00269 Published 2026-10-14 Fixed in 1.7.3 CWE-287
Priority MEDIUM 48

Better Auth from 1.4.0-beta.18 before 1.7.7 contains an authentication bypass vulnerability that allows unauthenticated attackers to sign in as other users by reusing OAuth state values as Magic Link tokens.

CVSS 4.0CRITICAL 9.3 Network No auth No interaction EPSS 0.00321 Published 2026-10-14 Fixed in 1.7.7 CWE-287
Priority LOW 27

Better Auth @better-auth/drizzle-adapter and better-auth from 1.6.17 before 1.7.7, and @better-auth/kysely-adapter from 1.6.17 before 1.7.0, contain a race condition in database-backed rate limiting on PostgreSQL where t…

CVSS 4.0MEDIUM 6.3 Network No auth No interaction EPSS 0.00217 Published 2026-10-14 Fixed in 1.7.7, 1.7.0 CWE-307
Priority LOW 39

better-auth from 1.3.8-beta.3 before 1.7.0-rc.3 contains a UI misrepresentation vulnerability in the deviceAuthorization plugin because GET /device omits the requesting client_id and scope.

CVSS 4.0HIGH 8.5 Network No auth User interaction EPSS 0.00278 Published 2026-10-12 Fixed in 1.7.0-rc.3 CWE-451
Priority LOW 39

@better-auth/sso before 1.6.27 (and before 1.4.8 in the 1.4.x line and before 1.7.0-rc.5 in the 1.7 prerelease line) contains two domain-ownership flaws.

CVSS 4.0HIGH 8.6 Network Low privileges No interaction EPSS 0.00363 Published 2026-08-25 Fixed in 1.4.8, 1.6.27 +1 CWE-287
Priority MEDIUM 40

better-auth (npm) before 1.4.2 allows an external request to configure baseURL when it is not otherwise defined (e.g., BETTER_AUTH_URL is unset).

CVSS 4.0CRITICAL 9.3 Network No auth No interaction EPSS 0.00455 Published 2026-08-02 Fixed in 1.4.2 CWE-770
Priority LOW 31

better-auth passkey versions before 1.4.0 contain an insecure direct object reference vulnerability in the passkey deletion endpoint that allows authenticated users to delete arbitrary passkeys by ID.

CVSS 4.0HIGH 7.1 Network Low privileges No interaction EPSS 0.00352 Published 2026-08-02 Fixed in 1.4.0 CWE-639
Priority MEDIUM 40

better-auth versions before 1.6.11 contain insecure cryptographic defaults in the oidcProvider and mcp plugins that advertise the none algorithm and accept plain PKCE by default.

CVSS 4.0CRITICAL 9.4 Network No auth No interaction EPSS 0.00236 Published 2026-08-01 Fixed in 1.6.11 CWE-327
Priority LOW 29

better-auth before 1.6.13 (and pre-release builds 1.7.0-beta.0 through 1.7.0-beta.3) fail to validate the scheme of redirect_uris registered via the deprecated oidc-provider plugin and the mcp plugin (which wraps the sam…

CVSS 4.0MEDIUM 5.1 Network Low privileges User interaction EPSS 0.00263 Published 2026-08-01 Fixed in 1.6.13, 1.7.0-beta.4 CWE-79
Priority LOW 23

better-auth versions before 1.6.11 fail to delete cached sessions when removing users via admin, anonymous, or SCIM endpoints when secondaryStorage is configured and storeSessionInDatabase is false.

CVSS 4.0MEDIUM 5.1 Network High privileges No interaction EPSS 0.00323 Published 2026-08-01 Fixed in 1.6.11 CWE-459
Priority LOW 31

better-auth versions before 1.1.20 contain a bypass vulnerability in trustedOrigins validation logic affecting absolute URLs and wildcard domains.

CVSS 4.0HIGH 7.1 Network No auth User interaction EPSS 0.00342 Published 2026-08-01 Fixed in 1.1.20 CWE-601
Priority LOW 24

@better-auth/oauth-provider before 1.7.0-beta.4 fails to bind access-token audience to the authorization grant, allowing clients to request tokens for unrelated resources.

CVSS 4.0MEDIUM 5.3 Network Low privileges No interaction EPSS 0.0026 Published 2026-08-01 Fixed in 1.7.0-beta.4 CWE-285
Priority MEDIUM 40

@better-auth/sso versions before 1.6.21 contain multiple authentication bypass vulnerabilities in SSO provider handling that allow attackers to sign in as arbitrary users.

CVSS 4.0HIGH 8.6 Network Low privileges No interaction EPSS 0.00491 Published 2026-08-01 Fixed in 1.6.21, 1.7.0-beta.10 CWE-79
Priority LOW 30

better-auth versions after v0.0.2 and before 1.1.16 contain a reflected cross-site scripting (XSS) vulnerability on the /api/auth/error page, where the value of the 'error' URL parameter is reflected as HTML without prop…

CVSS 4.0MEDIUM 5.1 Network No auth User interaction EPSS 0.00719 Published 2026-08-01 Fixed in 1.1.16 CWE-79
Priority MEDIUM 40

better-auth versions >= 1.1.3 and < 1.6.22 (and pre-release versions >= 1.7.0-beta.0 and < 1.7.0-beta.10) are vulnerable to account takeover via pre-account hijacking on magic-link and email-OTP sign-in when open email/p…

CVSS 4.0HIGH 8.7 Network No auth User interaction EPSS 0.00429 Published 2026-08-01 Fixed in 1.6.22, 1.7.0-beta.10 CWE-287
Priority HIGH 71

better-auth SCIM versions from 1.5.0 before 1.7.0-beta.4 fail to bind non-organization SCIM providers to their creator by default, allowing authenticated users to manage other users' providers.

CVSS 4.0HIGH 8.7 Network Low privileges No interaction EPSS 0.00388 Published 2026-08-01 Fixed in 1.7.0-beta.4 CWE-639
Priority LOW 27

better-auth versions before 1.6.2 fail to validate the OAuth state parameter against the stored nonce when using cookie-backed state storage without PKCE.

CVSS 4.0MEDIUM 6.0 Network No auth User interaction EPSS 0.00283 Published 2026-08-01 Fixed in 1.6.2 CWE-287
Priority LOW 16

better-auth versions greater than 1.3.34 and before 1.4.0 contain a vulnerability in the multi-session plugin's /sign-out after-hook, which trusts raw multi-session cookies and forwards extracted values to internalAdapte…

CVSS 4.0LOW 2.0 Network High privileges User interaction EPSS 0.00268 Published 2026-08-01 Fixed in 1.4.0 CWE-347
Load more