Read the docs

Vulnerabilities

Filters

Reset all
Threatist priority
Signals
Fix status
Impact type
Attack vector
Requirements
Product

Products as named in CPE, with their records.

Published
Weakness (CWE)
1 selected

47 records

Priority MEDIUM 41

The LiteSpeed Cache plugin for WordPress is vulnerable to unauthenticated disclosure of sensitive WooCommerce customer data in all versions up to, and including, 7.9.1 With Cache REST enabled (the shipped default cache-r…

CVSS 3.1HIGH 8.2 Network No auth No interaction EPSS 0.0023 Published 2026-11-05 No fix listed CWE-200
Priority HIGH 69

OpenLiteSpeed through 1.9.4 contains an authentication bypass vulnerability that allows unauthenticated remote attackers to evade virtual host client certificate requirements over HTTP/3.

CVSS 4.0HIGH 8.2 Network No auth No interaction EPSS 0.00289 Published 2026-10-30 No fix listed CWE-295
Priority LOW 24

The LiteSpeed Cache plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'comment' parameter in all versions up to, and including, 7.9.1 due to insufficient input sanitization and output escaping.

CVSS 3.1MEDIUM 5.4 Network No auth No interaction EPSS 0.00341 Published 2026-10-29 No fix listed CWE-79
Priority LOW 28

The LiteSpeed Cache plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'bbp_reply_content' parameter in all versions up to, and including, 7.9.1 due to insufficient input sanitization and output es…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.00334 Published 2026-10-29 No fix listed CWE-79
Priority LOW 39

In lsquic before 4.9.0, the HTTP/3 implementation can use an excessive amount of memory because the number of buffered header sets is not limited, as demonstrated by a QPACK amplification attack.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.00446 Published 2026-10-22 Fixed in 4.9.0 CWE-770
Priority LOW 25

OpenLiteSpeed before 1.9.3 contains a local privilege escalation vulnerability in admin/misc/lsup.sh that runs unverified update packages from a nobody-writable directory as root.

CVSS 4.0MEDIUM 5.4 Local Low privileges User interaction EPSS 0.00085 Published 2026-10-02 Fixed in 1.9.3 CWE-367
Priority MEDIUM 42

LiteSpeed Web Server (LSWS) before 6.3.7 build 1 mishandles internal redirect URL validation in a certain "corner case" of %252e%252e double decoding, letting a low-privileged tenant execute code in the context of a diff…

CVSS 4.0CRITICAL 9.4 Network Low privileges No interaction EPSS 0.00352 Published 2026-09-30 Fixed in 6.3.7 build 1 CWE-174
Priority LOW 22

The LiteSpeed Cache plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'esi' parameter in all versions up to, and including, 7.9 due to insufficient input sanitization and output escaping.

CVSS 3.1MEDIUM 4.7 Network No auth User interaction EPSS 0.00377 Published 2026-09-19 No fix listed CWE-79
Priority CRITICAL 96KEV

LiteSpeed cPanel plugin before 2.4.8 (as distributed in LiteSpeed WHM PlugIn before 5.3.2.0) mishandles symlinks provided by a user with FTP or web shell access on a shared hosting server running CloudLinux/CageFS, as ex…

CVSS 3.1HIGH 8.5 Network Low privileges No interaction EPSS 0.01439 Published 2026-06-14 Fixed in 2.4.8 CWE-61
Priority LOW 38

The LiteSpeed Cache plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the /wp-json/litespeed/v1/notify_ccss and /wp-json/litespeed/v1/notify_ucss REST API endpoints in all versions up to, and includin…

CVSS 3.1HIGH 7.2 Network No auth No interaction EPSS 0.00359 Published 2026-05-27 No fix listed CWE-79
Priority MEDIUM 42

OpenLiteSpeed and LSWS Enterprise provided by LiteSpeed Technologies contain an OS command injection vulnerability.

CVSS 4.0HIGH 8.6 Network High privileges No interaction EPSS 0.01471 Published 2026-03-16 No fix listed CWE-78
Priority LOW 27

The LiteSpeed Cache plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via URLs in all versions up to, and including, 7.5.0.1 due to insufficient input sanitization and output escaping.

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.00375 Published 2025-10-29 No fix listed CWE-79
Priority LOW 25

A hash collision vulnerability (in the hash table used to manage connections) in LSQUIC (aka LiteSpeed QUIC) before 4.2.0 allows remote attackers to cause a considerable CPU load on the server (a Hash DoS attack) by init…

CVSS 3.1MEDIUM 5.3 Network No auth No interaction EPSS 0.00679 Published 2025-02-20 Fixed in 4.2.0 CWE-407
Priority MEDIUM 45

Incorrect Privilege Assignment vulnerability in LiteSpeed Technologies LiteSpeed Cache litespeed-cache allows Privilege Escalation.This issue affects LiteSpeed Cache: from n/a through <= 6.5.1.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.00899 Published 2024-10-29 No fix listed CWE-266
Priority CRITICAL 90

Insufficiently Protected Credentials vulnerability in LiteSpeed Technologies LiteSpeed Cache litespeed-cache allows Authentication Bypass.This issue affects LiteSpeed Cache: from n/a through < 6.5.0.1.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.82335 Published 2024-10-20 No fix listed CWE-522
Priority MEDIUM 41

Relative Path Traversal vulnerability in LiteSpeed Technologies LiteSpeed Cache litespeed-cache allows Path Traversal.This issue affects LiteSpeed Cache: from n/a through <= 6.4.1.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.00647 Published 2024-10-16 No fix listed CWE-23
Priority LOW 28

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in LiteSpeed Technologies LiteSpeed Cache litespeed-cache allows Stored XSS.This issue affects LiteSpeed Cache: from n/a…

CVSS 3.1MEDIUM 6.5 Network Low privileges User interaction EPSS 0.00261 Published 2024-10-05 No fix listed CWE-79
Priority LOW 34

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in LiteSpeed Technologies LiteSpeed Cache litespeed-cache allows Stored XSS.This issue affects LiteSpeed Cache: from n/a…

CVSS 3.1HIGH 7.1 Network No auth User interaction EPSS 0.01396 Published 2024-10-05 No fix listed CWE-79
Priority LOW 25

The LiteSpeed Cache plugin for WordPress is vulnerable to Stored Cross-Site Scripting via plugin debug settings in all versions up to, and including, 6.4.1 due to insufficient input sanitization and output escaping.

CVSS 3.1MEDIUM 5.5 Network High privileges No interaction EPSS 0.00279 Published 2024-09-25 No fix listed CWE-79
Load more