Priority LOW 28
ONLYOFFICE DocumentServer before 10.0.0 contains an unauthenticated server-side request forgery vulnerability in the /downloadfile/:docid endpoint that allows remote attackers to bypass the private-IP request-filtering-a…
CVSS 4.0MEDIUM 6.3· Network · No auth · No interaction · EPSS 0.00398 · Published 2026-10-14 · Fixed in 10.0.0 CWE-918
Priority MEDIUM 42
A remote code execution vulnerability in ONLYOFFICE Document Server versions before10.0.0 allows an authenticated attacker with a valid Inbox-compatible JWT to execute arbitrary operating system commands as the ds servic…
CVSS 4.0HIGH 8.7· Network · Low privileges · No interaction · EPSS 0.01042 · Published 2026-10-14 · Fixed in 10.0 CWE-73
Priority LOW 28
ONLYOFFICE Docs before 9.2.1 allows XSS via the Color theme name.
CVSS 3.1MEDIUM 6.4· Network · Low privileges · No interaction · EPSS 0.002 · Published 2025-12-25 · Fixed in 9.2.1 CWE-79
Priority LOW 28
ONLYOFFICE Docs before 9.2.1 allows XSS via the Font field for the Multilevel list settings window.
CVSS 3.1MEDIUM 6.4· Network · Low privileges · No interaction · EPSS 0.002 · Published 2025-12-25 · Fixed in 9.2.1 CWE-79
Priority LOW 28
ONLYOFFICE Docs before 9.2.1 allows XSS in the textarea of the comment editing form.
CVSS 3.1MEDIUM 6.4· Network · Low privileges · No interaction · EPSS 0.00177 · Published 2025-12-24 · Fixed in 9.2.1 CWE-79
Priority MEDIUM 50
The ONLYOFFICE Docs plugin for WordPress is vulnerable to Privilege Escalation due to missing authorization within its oo.callback REST endpoint in versions 1.1.0 to 2.2.0.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.00851 · Published 2025-07-24 · No fix listed CWE-862
Priority MEDIUM 62
ONLYOFFICE Docs (DocumentServer) in versions equal and below 8.3.1 are affected by a reflected cross-site scripting (XSS) issue when opening files via the WOPI protocol.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.62356 · Published 2025-06-12 · No fix listed CWE-79
Priority MEDIUM 63
Path Traversal vulnerability in ONLYOFFICE Document Server before v8.0.1 allows a remote attacker to copy arbitrary files by manipulating the fileExt parameter in the /example/editor endpoint, leading to unauthorized acc…
CVSS 3.1MEDIUM 6.7· Local · No auth · No interaction · EPSS 0.0053 · Published 2025-04-01 · No fix listed CWE-22
Priority LOW 28
The ONLYOFFICE DocSpace plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'onlyoffice-docspace' shortcode in all versions up to, and including, 2.1.1 due to insufficient input sanitizatio…
CVSS 3.1MEDIUM 6.4· Network · Low privileges · No interaction · EPSS 0.00314 · Published 2024-12-12 · No fix listed CWE-79
Priority LOW 28
The ONLYOFFICE Docs plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'onlyoffice' shortcode in all versions up to, and including, 2.0.0 due to insufficient input sanitization and output…
CVSS 3.1MEDIUM 6.4· Network · Low privileges · No interaction · EPSS 0.00261 · Published 2024-12-06 · No fix listed CWE-79
Priority MEDIUM 60
ONLYOFFICE Docs before 8.1.0 allows XSS via a GeneratorFunction Object attack against a macro.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00526 · Published 2024-09-09 · No fix listed CWE-79
Priority MEDIUM 60
ONLYOFFICE Docs before 8.0.1 allows XSS because a macro is an immediately-invoked function expression (IIFE), and therefore a sandbox escape is possible by directly calling the constructor of the Function object.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00608 · Published 2024-09-09 · No fix listed CWE-79
Priority HIGH 72
Memory Exhaustion vulnerability in ONLYOFFICE Document Server 4.0.3 through 7.3.2 allows remote attackers to cause a denial of service via crafted JavaScript file.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.02206 · Published 2023-08-14 · No fix listed CWE-835
Priority HIGH 82
An out of bounds memory access vulnerability in ONLYOFFICE DocumentServer 4.0.3 through 7.3.2 allows remote attackers to run arbitrary code via crafted JavaScript file.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.02363 · Published 2023-08-14 · No fix listed CWE-787
Priority HIGH 82
A use after free issue discovered in ONLYOFFICE DocumentServer 4.0.3 through 7.3.2 allows remote attackers to run arbitrary code via crafted JavaScript file.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.02316 · Published 2023-08-14 · No fix listed CWE-416
Priority HIGH 82
Onlyoffice Community Server before v12.5.2 was discovered to contain a remote code execution (RCE) vulnerability via the component UploadProgress.ashx.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.05033 · Published 2023-06-22 · No fix listed CWE-22
Priority LOW 34
ONLYOFFICE Docs through 7.3 on certain Linux distributions allows local users to gain privileges via a Trojan horse libgcc_s.so.1 in the current working directory, which may be any directory in which an ONLYOFFICE docume…
CVSS 3.1HIGH 7.8· Local · No auth · User interaction · EPSS 0.003 · Published 2023-03-19 · No fix listed CWE-427
Priority MEDIUM 58
Given a malicious document provided by an attacker, the ONLYOFFICE Workspace DMS is vulnerable to a stored (persistent, or "Type II") cross-site scripting (XSS) condition.
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.00582 · Published 2023-02-07 · No fix listed CWE-79
Priority HIGH 70
ONLYOFFICE all versions as of 2021-11-08 is vulnerable to Server-Side Request Forgery (SSRF).
CVSS 3.1HIGH 8.1· Network · No auth · User interaction · EPSS 0.01273 · Published 2023-01-23 · No fix listed CWE-918
Priority MEDIUM 57
ONLYOFFICE all versions as of 2021-11-08 is vulnerable to Improper Input Validation.
CVSS 3.1MEDIUM 5.3· Network · No auth · User interaction · EPSS 0.01031 · Published 2023-01-23 · No fix listed CWE-20
Priority HIGH 72
ONLYOFFICE all versions as of 2021-11-08 is affected by Incorrect Access Control.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.01278 · Published 2023-01-23 · No fix listed CWE-306
Priority MEDIUM 60
ONLYOFFICE all versions as of 2021-11-08 is vulnerable to Cross Site Scripting (XSS).
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.0084 · Published 2023-01-23 · No fix listed CWE-79
Priority MEDIUM 52
ONLYOFFICE all versions as of 2021-11-08 is affected by Incorrect Access Control.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.0174 · Published 2023-01-23 · No fix listed CWE-287
Priority MEDIUM 41
ONLYOFFICE all versions as of 2021-11-08 is affected by Incorrect Access Control.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.01223 · Published 2023-01-23 · No fix listed CWE-287
Priority MEDIUM 52
Onlyoffice Document Server v6.0.0 and below and Core 6.1.0.26 and below were discovered to contain a heap overflow via the component DesktopEditor/fontengine/fontconverter/FontFileBase.h.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.07019 · Published 2022-06-01 · No fix listed CWE-787
Load more