Read the docs

Vulnerabilities

Filters

Reset all
Threatist priority
Signals
Fix status
Impact type
Attack vector
Requirements
Product

Products as named in CPE, with their records.

Published
Weakness (CWE)
1 selected

27 records

Priority LOW 28

The Simple Membership plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'country' parameter in all versions up to, and including, 4.8.4 due to insufficient input sanitization and output escaping.

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.0021 Published 2026-10-10 No fix listed CWE-79
Priority LOW 39

The Simple Membership plugin for WordPress is vulnerable to unauthorized modification of data and sensitive information disclosure in versions up to, and including, 4.8.3 via the resend-activation and email-activation en…

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.00374 Published 2026-10-03 No fix listed CWE-862
Priority LOW 31

The Simple Membership plugin for WordPress is vulnerable to Authentication Bypass leading to Administrator Account Takeover in versions up to, and including, 4.8.0.

CVSS 3.1MEDIUM 5.3 Network No auth No interaction EPSS 0.00583 Published 2026-09-01 No fix listed CWE-287
Priority LOW 30

The Simple Membership plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 4.7.5.

CVSS 3.1MEDIUM 5.3 Network No auth No interaction EPSS 0.00352 Published 2026-06-18 No fix listed CWE-862
Priority LOW 27

URL Redirection to Untrusted Site ('Open Redirect') vulnerability in wp.insider Simple Membership simple-membership allows Phishing.This issue affects Simple Membership: from n/a through <= 4.5.3.

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.00273 Published 2024-10-24 No fix listed CWE-601
Priority LOW 29

The Simple Membership plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'swpm_paypal_subscription_cancel_link' shortcode in all versions up to, and including, 4.4.5 due to insufficient in…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.00429 Published 2024-05-09 No fix listed CWE-79
Priority LOW 24

The Simple Membership plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'swpm_paypal_subscription_cancel_link' shortcode in all versions up to, and including, 4.4.3 due to insufficient in…

CVSS 3.1MEDIUM 5.4 Network Low privileges User interaction EPSS 0.0034 Published 2024-04-25 No fix listed CWE-79
Priority LOW 29

The Simple Membership plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'Display Name' parameter in all versions up to, and including, 4.4.2 due to insufficient input sanitization and output escap…

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.00867 Published 2024-03-13 No fix listed CWE-79
Priority LOW 20

The Affiliates Manager plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.9.34.

CVSS 3.1MEDIUM 4.3 Network No auth User interaction EPSS 0.00312 Published 2024-02-05 No fix listed CWE-352
Priority LOW 27

The Simple Membership plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘environment_mode’ parameter in all versions up to, and including, 4.3.8 due to insufficient input sanitization and outpu…

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.00377 Published 2024-01-11 No fix listed CWE-79
Priority LOW 32

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in smp7, wp.Insider Simple Membership allows Reflected XSS.This issue affects Simple Membership: from n/a through 4.3.8.

CVSS 3.1HIGH 7.1 Network No auth User interaction EPSS 0.00459 Published 2023-12-19 No fix listed CWE-79
Priority LOW 38

The Simple Membership plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the `list_type` parameter in versions up to, and including, 4.3.5 due to insufficient input sanitization and output escaping.

CVSS 3.1HIGH 7.2 Network No auth No interaction EPSS 0.00573 Published 2023-09-06 No fix listed CWE-79
Priority MEDIUM 58

The Simple Membership WordPress plugin before 4.2.2 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perf…

CVSS 3.1MEDIUM 5.4 Network Low privileges User interaction EPSS 0.00539 Published 2023-01-16 Fixed in 4.2.2
Priority LOW 35

The Simple Membership WP user Import plugin for WordPress is vulnerable to SQL Injection via the ‘orderby’ parameter in versions up to, and including, 1.7 due to insufficient escaping on the user supplied parameter.

CVSS 3.1HIGH 7.2 Network High privileges No interaction EPSS 0.00921 Published 2023-01-12 No fix listed CWE-89
Priority MEDIUM 45

The Simple Membership WordPress plugin before 4.1.3 allows user to change their membership at the registration stage due to insufficient checking of a user supplied parameter.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.01393 Published 2022-08-01 Fixed in 4.1.3 CWE-269
Priority MEDIUM 40

The Simple Membership WordPress plugin before 4.1.3 does not properly validate the membership_level parameter when editing a profile, allowing members to escalate to a higher membership level by using a crafted POST requ…

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.0118 Published 2022-08-01 Fixed in 4.1.3 CWE-269
Priority LOW 31

The Simple Membership WordPress plugin before 4.1.1 does not properly sanitise and escape parameters before outputting them back in AJAX actions, leading to Reflected Cross-Site Scripting

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.01802 Published 2022-06-13 Fixed in 4.1.1 CWE-79
Priority LOW 29

The Simple Membership WordPress plugin before 4.1.0 does not have CSRF check in place when deleting Transactions, which could allow attackers to make a logged in admin delete arbitrary transactions via a CSRF attack

CVSS 3.1MEDIUM 6.5 Network No auth User interaction EPSS 0.00531 Published 2022-03-21 Fixed in 4.1.0 CWE-352
Priority LOW 22

The Simple Membership WordPress plugin before 4.0.9 does not have CSRF check when deleting members in bulk, which could allow attackers to make a logged in admin delete them via a CSRF attack

CVSS 3.1MEDIUM 4.7 Network No auth User interaction EPSS 0.00471 Published 2022-02-28 Fixed in 4.0.9 CWE-352
Load more