Priority HIGH 82
The Simple-File-List Plugin for WordPress is vulnerable to Remote Code Execution in versions up to, and including, 4.2.2 via the rename function which can be used to rename uploaded PHP code with a png extension to use a…
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.43519 · Published 2025-07-12 · Fixed in 4.2.3 CWE-434
Priority MEDIUM 58
The Simple File List WordPress plugin before 6.1.13 does not sanitise and escape a generated URL before outputting it back in an attribute, leading to a Reflected Cross-Site Scripting which could be used against admins.
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.0062 · Published 2024-11-14 · Fixed in 6.1.13 CWE-79
Priority LOW 27
Auth. (admin+) Stored Cross-Site Scripting (XSS) vulnerability in Mitchell Bennis Simple File List plugin <= 6.1.9 versions.
CVSS 3.1MEDIUM 5.9· Network · High privileges · User interaction · EPSS 0.0048 · Published 2023-10-24 · No fix listed CWE-79
Priority MEDIUM 55
The Simple File List WordPress plugin before 6.0.10 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unf…
CVSS 3.1MEDIUM 4.8· Network · High privileges · User interaction · EPSS 0.00442 · Published 2023-03-27 · Fixed in 6.0.10 CWE-79
Priority LOW 29
The Simple File List WordPress plugin before 4.4.12 does not implement nonce checks, which could allow attackers to make a logged in admin create new page and change it's content via a CSRF attack.
CVSS 3.1MEDIUM 6.5· Network · No auth · User interaction · EPSS 0.00411 · Published 2022-10-10 · Fixed in 4.4.12 CWE-352
Priority LOW 23
The Simple File List WordPress plugin before 4.4.12 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unf…
CVSS 3.1MEDIUM 4.8· Network · High privileges · User interaction · EPSS 0.00597 · Published 2022-10-10 · Fixed in 4.4.12 CWE-79
Priority MEDIUM 60
The Simple File List WordPress plugin before 4.4.12 does not escape parameters before outputting them back in attributes, leading to Reflected Cross-Site Scripting
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.44095 · Published 2022-09-26 · Fixed in 4.4.12 CWE-79
Priority MEDIUM 51
The Simple File List WordPress plugin is vulnerable to Arbitrary File Download via the eeFile parameter found in the ~/includes/ee-downloader.php file due to missing controls which makes it possible unauthenticated attac…
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.19958 · Published 2022-04-19 · No fix listed CWE-22
Priority MEDIUM 52
WordPress Plugin Simple File List before 4.2.8 is prone to a vulnerability that lets attackers delete arbitrary files because the application fails to properly verify user-supplied input.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.07073 · Published 2020-05-13 · No fix listed CWE-22