Priority LOW 28
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in wpweaver Weaver Xtreme Theme Support weaverx-theme-support allows Stored XSS.This issue affects Weaver Xtreme Theme Su…
CVSS 3.1MEDIUM 6.5· Network · Low privileges · User interaction · EPSS 0.00127 · Published 2026-10-13 · No fix listed CWE-79
Priority LOW 32
The Turnkey bbPress by WeaverTheme plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 1.7.1 via deserialization of untrusted input in the wvrbbp_set_to_serialized_values() fu…
CVSS 3.1MEDIUM 6.6· Network · High privileges · No interaction · EPSS 0.00686 · Published 2026-08-16 · No fix listed CWE-502
Priority LOW 20
The Weaver Show Posts plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'add_class' parameter in all versions up to, and including, 1.8.1.
CVSS 3.1MEDIUM 4.4· Network · High privileges · No interaction · EPSS 0.00216 · Published 2026-03-21 · No fix listed CWE-79
Priority LOW 28
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in wpweaver Weaver Themes Shortcode Compatibility weaver-themes-shortcode-compatibility allows Stored XSS.This issue affe…
CVSS 3.1MEDIUM 6.5· Network · Low privileges · User interaction · EPSS 0.00223 · Published 2025-01-21 · No fix listed CWE-79
Priority LOW 27
The Turnkey bbPress by WeaverTheme plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘_wpnonce’ parameter in all versions up to, and including, 1.6.3 due to insufficient input sanitization and…
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00364 · Published 2025-01-04 · No fix listed CWE-79
Priority LOW 28
The Weaver Xtreme Theme Support plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's div shortcode in all versions up to, and including, 6.4 due to insufficient input sanitization and output…
CVSS 3.1MEDIUM 6.4· Network · Low privileges · No interaction · EPSS 0.00273 · Published 2024-06-05 · No fix listed CWE-79
Priority LOW 24
The Weaver Xtreme theme for WordPress is vulnerable to Stored Cross-Site Scripting via custom post meta in all versions up to, and including, 6.3.0 due to insufficient input sanitization and output escaping on user suppl…
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.00312 · Published 2024-01-11 · No fix listed CWE-79
Priority HIGH 67
The Weaver Xtreme Theme Support WordPress plugin before 6.3.1 unserialises the content of an imported file, which could lead to PHP object injections issues when a high privilege user import a malicious file and a suitab…
CVSS 3.1HIGH 7.2· Network · High privileges · No interaction · EPSS 0.01186 · Published 2023-10-16 · Fixed in 6.3.1 CWE-502
Priority LOW 29
The Weaver Show Posts Plugin for WordPress is vulnerable to stored Cross-Site Scripting due to insufficient escaping of the profile display name in versions up to, and including, 1.6.
CVSS 3.1MEDIUM 6.4· Network · Low privileges · No interaction · EPSS 0.00508 · Published 2023-06-09 · No fix listed CWE-79
Priority LOW 29
The Weaver Xtreme Theme for WordPress is vulnerable to stored Cross-Site Scripting due to insufficient escaping of the profile display name in versions up to, and including, 5.0.7.
CVSS 3.1MEDIUM 6.4· Network · Low privileges · No interaction · EPSS 0.00531 · Published 2023-06-09 · No fix listed CWE-79
Priority MEDIUM 58
The Weaver Xtreme Theme Support WordPress plugin before 6.2.7 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users…
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.00471 · Published 2023-04-24 · Fixed in 6.2.7