Priority LOW 38
The WPForms Pro plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Single Line Text and Paragraph Text Field Values in all versions up to, and including, 2.0.0.2 due to insufficient input sanitization…
CVSS 3.1HIGH 7.2· Network · No auth · No interaction · EPSS 0.00342 · Published 2026-08-21 · No fix listed CWE-79
Priority MEDIUM 42
The WPForms Pro plugin for WordPress is vulnerable to Arbitrary File Upload in all versions up to, and including, 1.10.1.1 via the ajax_chunk_upload_finalize function.
CVSS 3.1HIGH 8.1· Network · No auth · No interaction · EPSS 0.02482 · Published 2026-07-25 · No fix listed CWE-434
Priority MEDIUM 56
WPForms 1.7.8 contains a cross-site scripting vulnerability in the slider import search feature and tab parameter.
CVSS 4.0MEDIUM 5.1· Network · No auth · User interaction · EPSS 0.00375 · Published 2026-01-13 · No fix listed CWE-79
Priority MEDIUM 60
The Contact Form & SMTP Plugin for WordPress by PirateForms WordPress plugin before 2.6.0 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Si…
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00279 · Published 2025-03-25 · Fixed in 2.6.0 CWE-79
Priority MEDIUM 60
The Contact Form & SMTP Plugin for WordPress by PirateForms WordPress plugin before 2.6.0 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Si…
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00279 · Published 2025-03-25 · Fixed in 2.6.0 CWE-79
Priority LOW 29
The WPForms – Easy Form Builder for WordPress – Contact Forms, Payment Forms, Surveys, & More plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘fieldHTML’ parameter in all versions up to, and inc…
CVSS 3.1MEDIUM 6.4· Network · Low privileges · No interaction · EPSS 0.00386 · Published 2025-02-04 · No fix listed CWE-79
Priority LOW 38
Missing Authorization vulnerability in Syed Balkhi Contact Form by WPForms wpforms-lite allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Contact Form by WPForms: from n/a through…
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.00399 · Published 2025-01-07 · No fix listed CWE-862
Priority MEDIUM 55
The WPForms WordPress plugin before 1.9.2.3 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_…
CVSS 3.1MEDIUM 4.7· Network · High privileges · No interaction · EPSS 0.00523 · Published 2024-12-26 · Fixed in 1.9.2.3 CWE-79
Priority LOW 38
The WPForms plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'wpforms_is_admin_page' function in versions starting from 1.8.4 up to, and including, 1.9.2.1.
CVSS 3.1HIGH 8.5· Network · Low privileges · No interaction · EPSS 0.00722 · Published 2024-12-10 · No fix listed CWE-862
Priority LOW 17
The WPForms WordPress plugin before 1.9.1.6 does not sanitise and escape some of its settings, which could allow high privilege users such as Admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_…
CVSS 3.1LOW 3.5· Network · High privileges · User interaction · EPSS 0.00448 · Published 2024-11-25 · Fixed in 1.9.1.6 CWE-79
Priority LOW 20
The WPForms – Easy Form Builder for WordPress – Contact Forms, Payment Forms, Surveys, & More plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.9.1.6.
CVSS 3.1MEDIUM 4.3· Network · No auth · User interaction · EPSS 0.00272 · Published 2024-11-13 · No fix listed CWE-352
Priority LOW 37
Improper Privilege Management vulnerability in WPForms, LLC.
CVSS 3.1HIGH 8.0· Network · Low privileges · User interaction · EPSS 0.00366 · Published 2024-08-01 · No fix listed CWE-269
Priority LOW 38
The WPForms Pro plugin for WordPress is vulnerable to Stored Cross-Site Scripting via form submission parameters in all versions up to, and including, 1.8.5.3 due to insufficient input sanitization and output escaping.
CVSS 3.1HIGH 7.2· Network · No auth · No interaction · EPSS 0.0053 · Published 2024-01-20 · No fix listed CWE-79
Priority LOW 31
The WP Mail SMTP Pro plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the is_print_page function in versions up to, and including, 3.8.0.
CVSS 3.1MEDIUM 5.3· Network · No auth · No interaction · EPSS 0.00514 · Published 2023-10-04 · No fix listed CWE-862
Priority LOW 27
Unauth. Reflected Cross-Site Scripting (XSS) vulnerability in WPForms WPForms Lite (wpforms-lite), WPForms WPForms Pro (wpforms) plugins <= 1.8.1.2 versions.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00402 · Published 2023-06-22 · No fix listed CWE-79
Priority LOW 39
The Contact Form & SMTP Plugin by PirateForms plugin for WordPress is vulnerable to HTML injection in the ‘public/class-pirateforms-public.php’ file in versions up to, and including, 2.5.1 due to insufficient input sanit…
CVSS 3.1HIGH 7.2· Network · No auth · No interaction · EPSS 0.00657 · Published 2023-06-07 · Fixed in 2.5.2 CWE-79
Priority HIGH 82
The WPForms Pro WordPress plugin before 1.7.7 does not validate its form data when generating the exported CSV, which could lead to CSV injection.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.0144 · Published 2022-11-14 · Fixed in 1.7.7 CWE-1236
Priority LOW 32
A stored cross-site scripting (XSS) vulnerability exists in the WPForms Contact Form (aka wpforms-lite) plugin before 1.5.9 for WordPress.
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.04428 · Published 2020-03-11 · No fix listed CWE-79