Read the docs
Red Hat Security Advisory

RHSA-2017:1685

ansible security, bug fix, and enhancement update

Released 2017-07-06 · Red Hat rating Important · View on Red Hat →

Fixed in

Fixes 3 records

TI-2016-07808 CVE-2016-9587 · GHSA-m956-frf4-m2wr

Improper input validation in Ansible

Priority MEDIUM 52

Ansible before versions 2.1.4, 2.2.1 is vulnerable to an improper input validation in Ansible's handling of data sent from client systems.

CVSS 3.1HIGH 8.1 Network No auth No interaction EPSS 0.17006 Published 2018-04-24 Partial fix · 2.1.4.0, 2.2.1.0 CWE-20
Priority MEDIUM 40

Ansible before version 2.3 has an input validation vulnerability in the handling of data sent from client systems.

CVSS 3.0HIGH 8.0 Network Low privileges User interaction EPSS 0.03005 Published 2018-06-22 Fixed in 2.2.3.0 CWE-20
Priority LOW 25

An input validation vulnerability was found in Ansible's mysql_user module before 2.2.1.0, which may fail to correctly change a password in certain circumstances.

CVSS 3.1MEDIUM 4.9 Network High privileges No interaction EPSS 0.0144 Published 2018-07-26 Partial fix · 2.2.1.0 CWE-20