Read the docs
TI-2016-07109 Aliases CVE-2016-8647GHSA-x4cm-m36h-c6qj

Improper input validation in Red Hat Ansible

Priority LOW 25CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · High · None
Fix status
Partial Red Hat: 1 fixed, 2 without a fix

Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat.

Summary

An input validation vulnerability was found in Ansible's mysql_user module before 2.2.1.0, which may fail to correctly change a password in certain circumstances. Thus the previous password would still be active when it should have been changed.

Why it matters now

EPSS 0.0144 73rd percentileScored 2026-11-07
Fix Partial ansible (PyPI): 2.2.1.0Red Hat: 1 advisoryRed Hat: 1 fixed, 2 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
Red HatAnsible2.2.1.0—No fix listedCNA
—ansible (PyPI)before 2.2.1.02.2.1.0Patch availableGHSA-x4cm-m36h-c6qj
  • Ansible VendorRed Hat Affected 2.2.1.0 Fixed in — No fix listed CNA
  • ansible (PyPI) Vendor— Affected before 2.2.1.0 Fixed in 2.2.1.0 Patch available GHSA-x4cm-m36h-c6qj

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:redhat:ansible_engine:*:*:*:*:*:*:*:*before 2.2.1.0VulnerableRed Hat
cpe:2.3:a:redhat:virtualization:4.1:*:*:*:*:*:*:*4.1VulnerableRed Hat
  • cpe:2.3:a:redhat:ansible_engine:*:*:*:*:*:*:*:* Versions before 2.2.1.0 Vulnerable ·Red Hat
  • cpe:2.3:a:redhat:virtualization:4.1:*:*:*:*:*:*:* Versions 4.1 Vulnerable ·Red Hat

Remediation

  • Fix · GHSA-x4cm-m36h-c6qj ansible (PyPI) Fixed in 2.2.1.0 Advisory →

Red Hat 1 advisory

  • RHSA-2017:1685 Released 2017-07-06 · Red Hat rating Important
    ansible security, bug fix, and enhancement update
    • Red Hat Virtualization Manager 4.1 ansible-2.3.0.0-4.el7, ansible-doc-2.3.0.0-4.el7

Vendor assessments

Red Hat

Red Hat rating: Low. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat OpenShift Enterprise 3AffectedNo fix yet
Red Hat Quickstart Cloud Installer 1AffectedNo fix planned: Will not fix
Red Hat Virtualization Manager 4.1Fixed RHSA-2017:1685
Not affected: 4 products
  • Red Hat OpenStack Platform 10 (Newton)
  • Red Hat OpenStack Platform 11 (Ocata)
  • Red Hat Storage 3
  • Red Hat Storage Console 2

Timeline

  1. 2026-10-02 Threatist record created from CVE-2016-8647
  2. 2026-10-03 Alias added: GHSA-x4cm-m36h-c6qj

References

  • TI-2018-05593 transport.py in the SSH server implementation of Paramiko before 1.17.6, 1.18.x before… CVSS 3.1CRITICAL 9.8
  • TI-2017-05127 Improper input validation in [UNKNOWN] ansible CVSS 3.1CRITICAL 9.8
  • TI-2021-03523 Information disclosure in ansible CVSS 3.1HIGH 7.5
  • TI-2019-11051 Sensitive information in log files in Red Hat Ansible CVSS 3.1HIGH 7.8
  • TI-2018-07689 Untrusted search path in [UNKNOWN] ansible CVSS 3.1HIGH 7.8
  • TI-2018-07688 Untrusted search path in [UNKNOWN] ansible CVSS 3.0HIGH 7.8
See all 24 →

Sources