Read the docs
Red Hat Security Advisory

RHSA-2019:3892

Red Hat Fuse 7.5.0 security update

Released 2019-11-14 · Red Hat rating Important · View on Red Hat →

Fixed in

Fixes 27 records

TI-2019-07494 CVE-2019-10173 · GHSA-hf23-9pf7-388p

Code injection in xstream

Priority CRITICAL 86

It was found that xstream API version 1.4.10 before 1.4.11 introduced a regression for a previous deserialization flaw.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.95036 Published 2019-07-23 Fixed in 1.4.11 CWE-94
Priority MEDIUM 61

FasterXML jackson-databind 2.x before 2.9.7 might allow remote attackers to execute arbitrary code by leveraging failure to block the blaze-ds-opt and blaze-ds-core classes from polymorphic deserialization.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.09682 Published 2019-01-02 Partial fix · 2.9.7, 2.8.11.3 +1 CWE-502
Priority MEDIUM 60

A deserialization flaw was discovered in the jackson-databind in versions before 2.8.10 and 2.9.1, which could allow an unauthenticated user to perform code execution by sending the maliciously crafted input to the readV…

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.08357 Published 2018-02-06 Partial fix · 2.8.10, 2.9.1 +4 CWE-184
Priority MEDIUM 58

The host name verification when using TLS with the WebSocket client was missing.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.21048 Published 2018-08-01 Partial fix · 9.0.10, 8.5.32 +2 CWE-295
Priority MEDIUM 56

FasterXML jackson-databind 2.x before 2.9.7 might allow remote attackers to conduct server-side request forgery (SSRF) attacks by leveraging failure to block the axis2-jaxws class from polymorphic deserialization.

CVSS 3.0CRITICAL 10.0 Network No auth No interaction EPSS 0.10458 Published 2019-01-02 Partial fix · 2.9.7, 2.8.11.3 +1 CWE-918
Priority MEDIUM 52

FasterXML jackson-databind 2.x before 2.9.7 might allow attackers to conduct external XML entity (XXE) attacks by leveraging failure to block unspecified JDK classes from polymorphic deserialization.

CVSS 3.0CRITICAL 9.8 Network No auth No interaction EPSS 0.07524 Published 2019-01-02 Partial fix · 2.9.7, 2.8.11.3 +1 CWE-502
TI-2018-05786 CVE-2018-8009 · GHSA-6x48-j4x4-cqw3

Path traversal in Apache Hadoop

Priority MEDIUM 48

Apache Hadoop 3.1.0, 3.0.0-alpha to 3.0.2, 2.9.0 to 2.9.1, 2.8.0 to 2.8.4, 2.0.0-alpha to 2.7.6, 0.23.0 to 0.23.11 is exploitable via the zip slip vulnerability in places that accept a zip file.

CVSS 3.0HIGH 8.8 Network Low privileges No interaction EPSS 0.06734 Published 2018-11-13 Fixed in 3.1.1, 3.0.3 +3 CWE-22
TI-2018-08450 CVE-2018-11796 · GHSA-h8q5-g2cj-qr5h

XML external entity injection in Apache Tika

Priority MEDIUM 43

In Apache Tika 1.19 (CVE-2018-11761), we added an entity expansion limit for XML parsing.

CVSS 3.0HIGH 7.5 Network No auth No interaction EPSS 0.07537 Published 2018-10-09 Partial fix · 1.19.1 CWE-611
Priority MEDIUM 42

TLS hostname verification when using the Apache ActiveMQ Client before 5.15.6 was missing which could make the client vulnerable to a MITM attack between a Java application using the ActiveMQ client and the ActiveMQ serv…

CVSS 3.0HIGH 7.4 Network No auth No interaction EPSS 0.06959 Published 2018-09-10 Partial fix · 5.15.6 CWE-295
Priority MEDIUM 40

Square Retrofit version versions from (including) 2.0 and 2.5.0 (excluding) contains a Directory Traversal vulnerability in RequestBuilder class, method addPathParameter that can result in By manipulating the URL an atta…

CVSS 3.0HIGH 7.5 Network No auth No interaction EPSS 0.04033 Published 2018-12-20 Fixed in 2.5.0 CWE-22
Priority MEDIUM 40

Infinispan permits improper deserialization of trusted data via XML and JSON transcoders under certain server configurations.

CVSS 3.0HIGH 8.8 Network Low privileges No interaction EPSS 0.01186 Published 2018-05-15 Partial fix · 9.3.1.Final CWE-349
Priority LOW 39

A specifically crafted Docker image running under the root user can overwrite the init helper binary of the container runtime and/or the command executor in Apache Mesos versions pre-1.4.x, 1.4.0 to 1.4.2, 1.5.0 to 1.5.2…

CVSS 3.1HIGH 7.8 Local No auth User interaction EPSS 0.02712 Published 2019-03-25 Fixed in 1.4.3, 1.5.3 +2
TI-2019-00177 CVE-2019-0201 · GHSA-2hw2-62cp-p9p7

Missing authorization in Apache ZooKeeper

Priority LOW 39

An issue is present in Apache ZooKeeper 1.0.0 to 3.4.13 and 3.5.0-alpha to 3.5.4-beta.

CVSS 3.1MEDIUM 5.9 Network No auth No interaction EPSS 0.09712 Published 2019-05-23 Partial fix · 3.4.14, 3.5.5 CWE-862