A specifically crafted Docker image running under the root user can overwrite the init…
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat.
Summary
A specifically crafted Docker image running under the root user can overwrite the init helper binary of the container runtime and/or the command executor in Apache Mesos versions pre-1.4.x, 1.4.0 to 1.4.2, 1.5.0 to 1.5.2, 1.6.0 to 1.6.1, and 1.7.0 to 1.7.1. A malicious actor can therefore gain root-level code execution on the host.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Mesos | pre-1.4.x; 1.4.0 to 1.4.2; 1.5.0 to 1.5.2; 1.6.0 to 1.6.1; 1.7.0 to 1.7.1 | — | No fix listed | CNA |
| — | org.apache.mesos:mesos (Maven) | before 1.4.3 | 1.4.3 | Patch available | GHSA-32w9-2qpc-5f9v |
| — | org.apache.mesos:mesos (Maven) | 1.5.0 to before 1.5.3 | 1.5.3 | Patch available | GHSA-32w9-2qpc-5f9v |
| — | org.apache.mesos:mesos (Maven) | 1.6.0 to before 1.6.2 | 1.6.2 | Patch available | GHSA-32w9-2qpc-5f9v |
| — | org.apache.mesos:mesos (Maven) | 1.7.0 to before 1.7.2 | 1.7.2 | Patch available | GHSA-32w9-2qpc-5f9v |
- Apache Mesos VendorApache Affected pre-1.4.x; 1.4.0 to 1.4.2; 1.5.0 to 1.5.2; 1.6.0 to 1.6.1; 1.7.0 to 1.7.1 Fixed in — No fix listed CNA
- org.apache.mesos:mesos (Maven) Vendor— Affected before 1.4.3 Fixed in 1.4.3 Patch available GHSA-32w9-2qpc-5f9v
- org.apache.mesos:mesos (Maven) Vendor— Affected 1.5.0 to before 1.5.3 Fixed in 1.5.3 Patch available GHSA-32w9-2qpc-5f9v
- org.apache.mesos:mesos (Maven) Vendor— Affected 1.6.0 to before 1.6.2 Fixed in 1.6.2 Patch available GHSA-32w9-2qpc-5f9v
- org.apache.mesos:mesos (Maven) Vendor— Affected 1.7.0 to before 1.7.2 Fixed in 1.7.2 Patch available GHSA-32w9-2qpc-5f9v
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:mesos:*:*:*:*:*:*:*:* | 1.4.0 to before 1.4.3; 1.5.0 to before 1.5.3; 1.6.0 to before 1.6.2; 1.7.0 to before 1.7.2 | Vulnerable | Apache |
| cpe:2.3:a:apache:mesos:1.8.0:dev:*:*:*:*:*:* | 1.8.0 dev | Vulnerable | Apache |
| cpe:2.3:a:redhat:fuse:7.5.0:*:*:*:*:*:*:* | 7.5.0 | Vulnerable | Red Hat |
- cpe:2.3:a:apache:mesos:*:*:*:*:*:*:*:* Versions 1.4.0 to before 1.4.3; 1.5.0 to before 1.5.3; 1.6.0 to before 1.6.2; 1.7.0 to before 1.7.2 Vulnerable ·Apache
- cpe:2.3:a:apache:mesos:1.8.0:dev:*:*:*:*:*:* Versions 1.8.0 dev Vulnerable ·Apache
- cpe:2.3:a:redhat:fuse:7.5.0:*:*:*:*:*:*:* Versions 7.5.0 Vulnerable ·Red Hat
Remediation
- Fix · GHSA-32w9-2qpc-5f9v org.apache.mesos:mesos (Maven) Fixed in 1.4.3 Advisory →
- Fix · GHSA-32w9-2qpc-5f9v org.apache.mesos:mesos (Maven) Fixed in 1.5.3 Advisory →
- Fix · GHSA-32w9-2qpc-5f9v org.apache.mesos:mesos (Maven) Fixed in 1.6.2 Advisory →
- Fix · GHSA-32w9-2qpc-5f9v org.apache.mesos:mesos (Maven) Fixed in 1.7.2 Advisory →
Red Hat 1 advisory
- RHSA-2019:3892 Released 2019-11-14 · Red Hat rating ImportantRed Hat Fuse 7.5.0 security update
- Red Hat Fuse 7.5.0
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Fuse 7.5.0 | Fixed | RHSA-2019:3892 |
Timeline
- 2026-10-02 Threatist record created from CVE-2019-0204
- 2026-10-03 Alias added: GHSA-32w9-2qpc-5f9v
References
More Apache Mesos vulnerabilities
- TI-2019-04061 runc through 1.0-rc6, as used in Docker before 18.09.2 and other products, allows… CVSS 3.1HIGH 8.6
- TI-2018-08449 Memory corruption in Apache Mesos CVSS 3.0HIGH 7.5
- TI-2018-01231 Improper input validation in Apache Mesos CVSS 3.0HIGH 7.5
- TI-2017-07170 Use after free in Apache Mesos CVSS 3.0HIGH 7.5
- TI-2017-05323 When handling a decoding failure for a malformed URL path of an HTTP request, libprocess… CVSS 3.0HIGH 7.5
- TI-2018-15893 An improper authorization vulnerability exists in Jenkins Mesos Plugin 0.17.1 and earlier… CVSS 3.0MEDIUM 6.5
Sources
- CVE-2019-0204 · CVE Program
- CVE-2019-0204 · NVD
- FIRST EPSS
- GHSA-32w9-2qpc-5f9v · GitHub Advisory Database · CC BY 4.0
- CVE-2019-0204 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences