Ad Inserter < 2.7.12 - Reflected Cross-Site Scripting
Priority LOW 34CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Ad Inserter Free and Pro WordPress plugins before 2.7.12 do not sanitise and escape the REQUEST_URI before outputting it back in an admin page, leading to a Reflected Cross-Site Scripting in browsers which do not encode characters
Why it matters now
EPSS 0.03596 89th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed Ad Inserter – Ad Manager & AdSense Ads (Unknown): 2.7.12Ad Inserter Pro (Unknown): 2.7.12
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Ad Inserter – Ad Manager & AdSense Ads | 2.7.12 to before 2.7.12 | 2.7.12 | Patch available | CNA |
| Unknown | Ad Inserter Pro | 2.7.12 to before 2.7.12 | 2.7.12 | Patch available | CNA |
- Ad Inserter – Ad Manager & AdSense Ads VendorUnknown Affected 2.7.12 to before 2.7.12 Fixed in 2.7.12 Patch available CNA
- Ad Inserter Pro VendorUnknown Affected 2.7.12 to before 2.7.12 Fixed in 2.7.12 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:ad_inserter_project:ad_inserter:*:*:*:*:free:wordpress:*:* | before 2.7.12 | Vulnerable | Ad Inserter Project |
| cpe:2.3:a:ad_inserter_project:ad_inserter:*:*:*:*:pro:wordpress:*:* | before 2.7.12 | Vulnerable | Ad Inserter Project |
- cpe:2.3:a:ad_inserter_project:ad_inserter:*:*:*:*:free:wordpress:*:* Versions before 2.7.12 Vulnerable ·Ad Inserter Project
- cpe:2.3:a:ad_inserter_project:ad_inserter:*:*:*:*:pro:wordpress:*:* Versions before 2.7.12 Vulnerable ·Ad Inserter Project
Remediation
- Fix · CNA Ad Inserter – Ad Manager & AdSense Ads (Unknown) Fixed in 2.7.12
- Fix · CNA Ad Inserter Pro (Unknown) Fixed in 2.7.12
Timeline
- 2026-10-02 Threatist record created from CVE-2022-0901
- 2026-10-03 Alias added: GHSA-hj7f-7vcm-jv3j
References
More Ad Inserter Project Ad Inserter vulnerabilities
- TI-2023-01463 Ad Inserter < 2.7.27 - Admin+ PHP Object Injection CVSS 3.1HIGH 7.2
- TI-2019-11428 The ad-inserter plugin before 2.4.22 for WordPress has remote code execution. CVSS 3.0HIGH 8.8
- TI-2023-04301 Ad Inserter <= 2.7.30 - Unauthenticated Sensitive Information Exposure via ai-debug-processing-fe CVSS 3.1HIGH 7.5
- TI-2015-07874 The ad-inserter plugin before 1.5.3 for WordPress has CSRF with resultant XSS via… CVSS 3.1HIGH 8.8
- TI-2019-11427 The ad-inserter plugin before 2.4.20 for WordPress has path traversal. CVSS 3.1HIGH 7.5
- TI-2022-00220 Ad Inserter < 2.7.10 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
Sources
- CVE-2022-0901 · CVE Program
- CVE-2022-0901 · NVD
- FIRST EPSS
- GHSA-hj7f-7vcm-jv3j · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences